summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4b51b87..10815b7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -155,6 +155,19 @@ if(USE_DATABASE)
endif()
#
+## identd
+#
+file(GLOB source_identd
+ src/identd/*.[hc]pp)
+add_library(identd STATIC ${source_identd})
+target_link_libraries(identd bridge network utils src_utils logger)
+
+if(USE_DATABASE)
+ target_link_libraries(xmpp database)
+ target_link_libraries(irc database)
+endif()
+
+#
## bridge
#
file(GLOB source_bridge
@@ -172,6 +185,7 @@ target_link_libraries(${PROJECT_NAME}
bridge
utils
src_utils
+ identd
config)
if(SYSTEMD_FOUND)
target_link_libraries(xmpp ${SYSTEMD_LIBRARIES})