summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt2
-rw-r--r--cmake/Modules/FindIconv.cmake78
2 files changed, 39 insertions, 41 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 81ecaaf..3011fd3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,7 +23,7 @@ find_package(EXPAT REQUIRED)
include_directories("src/")
include_directories(${EXPAT_INCLUDE_DIRS})
-include_directories(${ICONV_INCLUDE_DIR})
+include_directories(${ICONV_INCLUDE_DIRS})
# the SYSTEM flag tells the compiler that we don't care about warnings
# coming from these headers.
include_directories(SYSTEM ${CRYPTO++_INCLUDE_DIRS})
diff --git a/cmake/Modules/FindIconv.cmake b/cmake/Modules/FindIconv.cmake
index c957af6..ac81a2c 100644
--- a/cmake/Modules/FindIconv.cmake
+++ b/cmake/Modules/FindIconv.cmake
@@ -1,29 +1,40 @@
-# - Try to find Iconv
-# Once done this will define
+# - Find iconv
+# Find the iconv (character set conversion) library
#
-# ICONV_FOUND - system has Iconv
-# ICONV_INCLUDE_DIR - the Iconv include directory
-# ICONV_LIBRARIES - Link these to use Iconv
-# ICONV_SECOND_ARGUMENT_IS_CONST - the second argument for iconv() is const
+# This module defines the following variables:
+# ICONV_FOUND - True if library and include directory are found
+# If set to TRUE, the following are also defined:
+# ICONV_INCLUDE_DIRS - The directory where to find the header file
+# ICONV_LIBRARIES - Where to find the library file
+# ICONV_SECOND_ARGUMENT_IS_CONST - The second argument for iconv() is const
#
-include(CheckCXXSourceCompiles)
-
-IF (ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
- # Already in cache, be silent
- SET(ICONV_FIND_QUIETLY TRUE)
-ENDIF (ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
+# For conveniance, these variables are also set. They have the same values
+# than the variables above. The user can thus choose his/her prefered way
+# to way to write them.
+# ICONV_LIBRARY
+# ICONV_INCLUDE_DIR
+#
+# This file is in the public domain
-FIND_PATH(ICONV_INCLUDE_DIR iconv.h)
+find_path(ICONV_INCLUDE_DIRS NAMES iconv.h
+ DOC "The iconv include directory")
-FIND_LIBRARY(ICONV_LIBRARIES NAMES iconv libiconv libiconv-2 c)
+find_library(ICONV_LIBRARIES NAMES iconv libiconv libiconv-2 c
+ DOC "The iconv library")
-IF(ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
- SET(ICONV_FOUND TRUE)
-ENDIF(ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
+# Use some standard module to handle the QUIETLY and REQUIRED arguments, and
+# set ICONV_FOUND to TRUE if these two variables are set.
+include(FindPackageHandleStandardArgs)
+find_package_handle_standard_args(Iconv REQUIRED_VARS ICONV_LIBRARIES ICONV_INCLUDE_DIRS)
-set(CMAKE_REQUIRED_INCLUDES ${ICONV_INCLUDE_DIR})
-set(CMAKE_REQUIRED_LIBRARIES ${ICONV_LIBRARIES})
-IF(ICONV_FOUND)
+# Check if the prototype is
+# size_t iconv(iconv_t cd, char** inbuf, size_t* inbytesleft,
+# char** outbuf, size_t* outbytesleft);
+# or
+# size_t iconv (iconv_t cd, const char** inbuf, size_t* inbytesleft,
+# char** outbuf, size_t* outbytesleft);
+if(ICONV_FOUND)
+ include(CheckCXXSourceCompiles)
check_cxx_source_compiles("
#include <iconv.h>
int main(){
@@ -33,25 +44,12 @@ IF(ICONV_FOUND)
char* out = 0;
size_t olen = 0;
iconv(conv, &in, &ilen, &out, &olen);
- return 0;
- }
-" ICONV_SECOND_ARGUMENT_IS_CONST )
-ENDIF(ICONV_FOUND)
-set(CMAKE_REQUIRED_INCLUDES)
-set(CMAKE_REQUIRED_LIBRARIES)
+ return 0;}"
+ ICONV_SECOND_ARGUMENT_IS_CONST)
-IF(ICONV_FOUND)
- IF(NOT ICONV_FIND_QUIETLY)
- MESSAGE(STATUS "Found Iconv: ${ICONV_LIBRARIES}")
- ENDIF(NOT ICONV_FIND_QUIETLY)
-ELSE(ICONV_FOUND)
- IF(Iconv_FIND_REQUIRED)
- MESSAGE(FATAL_ERROR "Could not find Iconv")
- ENDIF(Iconv_FIND_REQUIRED)
-ENDIF(ICONV_FOUND)
+# Compatibility for all the ways of writing these variables
+ set(ICONV_LIBRARY ${ICONV_LIBRARIES})
+ set(ICONV_INCLUDE_DIR ${ICONV_INCLUDE_DIRS})
+endif()
-MARK_AS_ADVANCED(
- ICONV_INCLUDE_DIR
- ICONV_LIBRARIES
- ICONV_SECOND_ARGUMENT_IS_CONST
-) \ No newline at end of file
+mark_as_advanced(ICONV_INCLUDE_DIRS ICONV_LIBRARIES ICONV_SECOND_ARGUMENT_IS_CONST) \ No newline at end of file