summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdebian/copyright-check27
-rwxr-xr-xdebian/rules2
2 files changed, 27 insertions, 2 deletions
diff --git a/debian/copyright-check b/debian/copyright-check
new file mode 100755
index 0000000..1f715d9
--- /dev/null
+++ b/debian/copyright-check
@@ -0,0 +1,27 @@
+#!/bin/sh
+# Copyright © 2016-2017 Jonas Smedegaard <dr@jones.dk>
+# Description: helper script to update copyright_hints
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+set -eu
+
+# extract metadata from binary media files
+#export DEB_COPYRIGHT_EXTRACT_EXTS=png
+
+make -f /usr/share/cdbs/1/rules/utils.mk pre-build || true
+make -f /usr/share/cdbs/1/rules/utils.mk clean DEB_COPYRIGHT_CHECK_STRICT=1
+
+# unconditionally merge changes - safe to do with git-tracked package
+[ ! -f debian/copyright_newhints ] || mv -f debian/copyright_newhints debian/copyright_hints
diff --git a/debian/rules b/debian/rules
index 51835bf..15bfd85 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,8 +18,6 @@
# along with this program. If not, see <http://www.gnu.org/licenses/>.
include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/rules/utils.mk
-
include /usr/share/cdbs/1/class/cmake.mk
pkg = $(DEB_SOURCE_PACKAGE)