summaryrefslogtreecommitdiff
path: root/docker
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2017-06-28 14:41:33 +0200
committerlouiz’ <louiz@louiz.org>2017-06-28 14:41:33 +0200
commit13a1ab1878fd6312aea485ded3f5bad59c36f17f (patch)
tree071b90523126d677f714cbf13346507f2e500d69 /docker
parenta1349361d2c15929e8260536c9091f2a4c2048a4 (diff)
parent7e69d0387e85eeed10d605349feeba595c3fa0ee (diff)
downloadbiboumi-13a1ab1878fd6312aea485ded3f5bad59c36f17f.tar.gz
biboumi-13a1ab1878fd6312aea485ded3f5bad59c36f17f.tar.bz2
biboumi-13a1ab1878fd6312aea485ded3f5bad59c36f17f.tar.xz
biboumi-13a1ab1878fd6312aea485ded3f5bad59c36f17f.zip
Merge remote-tracking branch 'remotes/debian/master' into debian
Diffstat (limited to 'docker')
-rw-r--r--docker/biboumi-test/alpine/Dockerfile10
-rw-r--r--docker/biboumi-test/alpine/Dockerfile.base51
-rw-r--r--docker/biboumi-test/archlinux/Dockerfile13
-rw-r--r--docker/biboumi-test/debian/Dockerfile.base1
-rw-r--r--docker/biboumi-test/fedora/Dockerfile.base2
-rw-r--r--docker/biboumi/Dockerfile36
-rw-r--r--docker/biboumi/README.md16
-rw-r--r--docker/biboumi/biboumi.cfg8
-rw-r--r--docker/biboumi/entrypoint.sh11
-rw-r--r--docker/packaging/debian/Dockerfile10
10 files changed, 117 insertions, 41 deletions
diff --git a/docker/biboumi-test/alpine/Dockerfile b/docker/biboumi-test/alpine/Dockerfile
new file mode 100644
index 0000000..ab288b6
--- /dev/null
+++ b/docker/biboumi-test/alpine/Dockerfile
@@ -0,0 +1,10 @@
+# This Dockerfile creates a docker image suitable to run biboumi’s build and
+# tests. For example, it can be used on with gitlab-ci.
+
+FROM docker.louiz.org/biboumi-test-alpine-base
+
+# Install litesql
+RUN git clone git://git.louiz.org/litesql && mkdir /litesql/build && cd /litesql/build && cmake .. -DCMAKE_INSTALL_PREFIX=/usr && make -j8 && cd /litesql/build && make install && rm -rf /litesql && ldconfig || true
+
+WORKDIR /home/tester
+USER tester
diff --git a/docker/biboumi-test/alpine/Dockerfile.base b/docker/biboumi-test/alpine/Dockerfile.base
new file mode 100644
index 0000000..dffa1d1
--- /dev/null
+++ b/docker/biboumi-test/alpine/Dockerfile.base
@@ -0,0 +1,51 @@
+# This Dockerfile creates a docker image suitable to run biboumi’s build and
+# tests. For example, it can be used on with gitlab-ci.
+
+FROM docker.io/alpine:latest
+
+ENV LC_ALL C.UTF-8
+
+# Needed to build biboumi
+RUN apk add --no-cache g++\
+ clang\
+ valgrind\
+ udns-dev\
+ c-ares-dev\
+ sqlite-dev\
+ libuuid\
+ util-linux-dev\
+ libgcrypt-dev\
+ cmake\
+ make\
+ expat-dev\
+ libidn-dev\
+ git\
+ py3-lxml\
+ libtool\
+ py3-pip\
+ python2\
+ python3-dev\
+ automake\
+ autoconf\
+ flex\
+ bison\
+ libltdl\
+ openssl\
+ libressl-dev\
+ zlib-dev\
+ curl
+
+# Install botan
+RUN git clone https://github.com/randombit/botan.git && cd botan && ./configure.py --prefix=/usr && make -j8 && make install && rm -rf /botan
+
+# Install slixmpp, for e2e tests
+RUN git clone https://github.com/saghul/aiodns.git && cd aiodns && git checkout 7ee13f9bea25784322~ && python3 setup.py build && python3 setup.py install && git clone git://git.louiz.org/slixmpp && pip3 install pyasn1 && cd slixmpp && python3 setup.py build && python3 setup.py install
+
+RUN adduser tester -D -h /home/tester
+
+# Install charybdis, for e2e tests
+RUN git clone https://github.com/charybdis-ircd/charybdis.git && cd charybdis && cd /charybdis && git checkout 4f2b9a4 && sed s/113/1113/ -i /charybdis/authd/providers/ident.c && ./autogen.sh && ./configure --prefix=/home/tester/ircd --bindir=/usr/bin && make -j8 && make install && rm -rf /charybdis
+
+RUN chown -R tester:tester /home/tester/ircd
+
+RUN yes "" | openssl req -nodes -x509 -newkey rsa:4096 -keyout /home/tester/ircd/etc/ssl.key -out /home/tester/ircd/etc/ssl.pem
diff --git a/docker/biboumi-test/archlinux/Dockerfile b/docker/biboumi-test/archlinux/Dockerfile
new file mode 100644
index 0000000..20f0343
--- /dev/null
+++ b/docker/biboumi-test/archlinux/Dockerfile
@@ -0,0 +1,13 @@
+FROM docker.io/base/archlinux:latest
+
+RUN pacman -Syuuuu --noconfirm
+
+RUN pacman -Syu --noconfirm cmake base-devel git clang-tools-extra
+
+RUN useradd -m -G wheel -s /bin/bash builder
+
+RUN sed -i '/^# %wheel ALL=(ALL) NOPASSWD: ALL/s/^# //' /etc/sudoers
+
+WORKDIR /home/builder
+
+USER builder
diff --git a/docker/biboumi-test/debian/Dockerfile.base b/docker/biboumi-test/debian/Dockerfile.base
index e609feb..f5d061b 100644
--- a/docker/biboumi-test/debian/Dockerfile.base
+++ b/docker/biboumi-test/debian/Dockerfile.base
@@ -12,6 +12,7 @@ RUN apt install -y g++\
clang\
valgrind\
libudns-dev\
+ libc-ares-dev\
libsqlite3-dev\
libuuid1\
libgcrypt20-dev\
diff --git a/docker/biboumi-test/fedora/Dockerfile.base b/docker/biboumi-test/fedora/Dockerfile.base
index dd536e5..20984a2 100644
--- a/docker/biboumi-test/fedora/Dockerfile.base
+++ b/docker/biboumi-test/fedora/Dockerfile.base
@@ -10,6 +10,7 @@ RUN dnf --refresh install -y\
clang\
valgrind\
udns-devel\
+ c-ares-devel\
sqlite-devel\
libuuid-devel\
libgcrypt-devel\
@@ -56,4 +57,3 @@ RUN chown -R tester:tester /home/tester/ircd
RUN yes "" | openssl req -nodes -x509 -newkey rsa:4096 -keyout /home/tester/ircd/etc/ssl.key -out /home/tester/ircd/etc/ssl.pem
COPY coverity /home/tester/coverity
-COPY sonar-scanner-2.8 /home/tester/sonar-scanner
diff --git a/docker/biboumi/Dockerfile b/docker/biboumi/Dockerfile
index 721d106..d27421b 100644
--- a/docker/biboumi/Dockerfile
+++ b/docker/biboumi/Dockerfile
@@ -1,26 +1,25 @@
# This Dockerfile creates a docker image running biboumi
-FROM docker.io/fedora:latest
+FROM docker.io/alpine:latest
-RUN dnf --refresh install -y\
- gcc-c++\
+RUN apk add --no-cache\
+ g++\
cmake\
make\
- udns-devel\
- sqlite-devel\
- libuuid-devel\
- expat-devel\
- libidn-devel\
- systemd-devel\
+ udns-dev\
+ sqlite-dev\
+ libuuid\
+ util-linux-dev\
+ expat-dev\
+ libidn-dev\
git\
- python\
- && dnf clean all
+ python2
# Install botan
-RUN git clone https://github.com/randombit/botan.git && cd botan && ./configure.py --prefix=/usr && make -j8 && make install && ldconfig && rm -rf /botan
+RUN git clone https://github.com/randombit/botan.git && cd botan && ./configure.py --prefix=/usr && make -j8 && make install && rm -rf /botan
# Install litesql
-RUN git clone git://git.louiz.org/litesql && mkdir /litesql/build && cd /litesql/build && cmake .. -DCMAKE_INSTALL_PREFIX=/usr && make -j8 && cd /litesql/build && make install && ldconfig && rm -rf /litesql
+RUN git clone git://git.louiz.org/litesql && mkdir /litesql/build && cd /litesql/build && cmake .. -DCMAKE_INSTALL_PREFIX=/usr && make -j8 && cd /litesql/build && make install && rm -rf /litesql
# Install biboumi
RUN git clone git://git.louiz.org/biboumi && mkdir ./biboumi/build && cd ./biboumi/build &&\
@@ -29,10 +28,9 @@ RUN git clone git://git.louiz.org/biboumi && mkdir ./biboumi/build && cd ./bibou
-DWITH_BOTAN=1\
-DWITH_LITESQL=1\
-DWITH_LIBIDN=1\
- -DWITH_SYSTEMD=1\
&& make -j8 && make install && rm -rf /biboumi
-RUN useradd biboumi
+RUN adduser biboumi -D -h /home/biboumi
RUN mkdir /var/lib/biboumi
RUN chown -R biboumi:biboumi /var/lib/biboumi
@@ -40,9 +38,7 @@ RUN chown -R biboumi:biboumi /var/lib/biboumi
COPY ./biboumi.cfg /etc/biboumi/biboumi.cfg
RUN chown -R biboumi:biboumi /etc/biboumi
-COPY ./entrypoint.sh /entrypoint.sh
-RUN chmod 755 /entrypoint.sh
-
-ENTRYPOINT ["/entrypoint.sh"]
-
+WORKDIR /home/biboumi
USER biboumi
+
+CMD ["/usr/bin/biboumi", "/etc/biboumi/biboumi.cfg"]
diff --git a/docker/biboumi/README.md b/docker/biboumi/README.md
index e69c1b0..4b9e1e5 100644
--- a/docker/biboumi/README.md
+++ b/docker/biboumi/README.md
@@ -32,14 +32,12 @@ docker run --network=host \
Variables
---------
-The configuration file inside the image is a template that is completed when the container is started, using the following environment variables:
+The configuration file inside the image contains only a few default values. To be able to run, biboumi needs additional configuration. Additional options can be passed using environment variables. Any configuration option can be customized this way (see biboumi’s doc), but the main are listed here for convenience:
* BIBOUMI_HOSTNAME: Sets the value of the *hostname* option.
-* BIBOUMI_SECRET: Sets the value of the *password* option.
+* BIBOUMI_PASSWORD: Sets the value of the *password* option.
* BIBOUMI_ADMIN: Sets the value of the *admin* option.
-* BIBOUMI_XMPP_SERVER_IP: Sets the value of the *xmpp_server_ip* option. The default is **xmpp**.
-
-All these variables are optional, but biboumi will probably fail to start if the hostname and secret are missing.
+* BIBOUMI_XMPP_SERVER_IP: Sets the value of the *xmpp_server_ip* option. The default value is **xmpp**.
You can also directly provide your own configuration file by mounting it inside the container using the -v option:
@@ -49,6 +47,8 @@ docker run --link prosody:xmpp \
biboumi
```
+If both a custom configuration file and custom environment variables are passed to the container, the environment variables will take precedence.
+
Linking with the XMPP server
----------------------------
@@ -60,3 +60,9 @@ Volumes
-------
The database is stored in the /var/lib/biboumi/ directory. If you don’t bind a local directory to it, the database will be lost when the container is stopped. If you want to keep your database between each run, bind it with the -v option, like this: **-v /srv/biboumi/:/var/lib/biboumi**.
+
+Note: Due to a limitation in Docker, to be able to read and write into this database, make sure this mounted directory is owned by UID and GID 1001:1001, on the host.
+
+```
+chown -R 1001:1001 database/
+```
diff --git a/docker/biboumi/biboumi.cfg b/docker/biboumi/biboumi.cfg
index cc5df61..98c5a9f 100644
--- a/docker/biboumi/biboumi.cfg
+++ b/docker/biboumi/biboumi.cfg
@@ -1,6 +1,6 @@
-xmpp_server_ip=BIBOUMI_XMPP_SERVER_IP
+xmpp_server_ip=127.0.0.1
port=5347
db_name=/var/lib/biboumi/biboumi.sqlite
-hostname=BIBOUMI_HOSTNAME
-password=BIBOUMI_PASSWORD
-admin=BIBOUMI_ADMIN
+hostname=xmpp
+password=
+admin=
diff --git a/docker/biboumi/entrypoint.sh b/docker/biboumi/entrypoint.sh
deleted file mode 100644
index eda53a4..0000000
--- a/docker/biboumi/entrypoint.sh
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/bash
-
-sed -i s/BIBOUMI_XMPP_SERVER_IP/${BIBOUMI_XMPP_SERVER_IP:-xmpp}/ /etc/biboumi/biboumi.cfg
-sed -i s/BIBOUMI_HOSTNAME/${BIBOUMI_HOSTNAME:-biboumi.localhost}/ /etc/biboumi/biboumi.cfg
-sed -i s/BIBOUMI_ADMIN/${BIBOUMI_ADMIN:-}/ /etc/biboumi/biboumi.cfg
-sed -i s/BIBOUMI_PASSWORD/${BIBOUMI_PASSWORD:-missing_password}/ /etc/biboumi/biboumi.cfg
-
-echo "Running biboumi with the following conf: "
-cat /etc/biboumi/biboumi.cfg
-
-/usr/bin/biboumi /etc/biboumi/biboumi.cfg
diff --git a/docker/packaging/debian/Dockerfile b/docker/packaging/debian/Dockerfile
new file mode 100644
index 0000000..f9f4d84
--- /dev/null
+++ b/docker/packaging/debian/Dockerfile
@@ -0,0 +1,10 @@
+# This Dockerfile creates a docker image suitable to build a debian package
+
+FROM docker.io/debian:sid
+
+RUN apt update
+
+# Needed to build biboumi
+RUN apt install -y \
+ git \
+ devscripts