summaryrefslogtreecommitdiff
path: root/docker/biboumi-test/debian/Dockerfile
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2016-12-24 15:31:53 +0100
committerlouiz’ <louiz@louiz.org>2016-12-24 16:20:50 +0100
commit16feed7e9e3c215625a62d444d7fa62c2a707c28 (patch)
treece13856cc64d293b543c80586a3c90d89789dbe6 /docker/biboumi-test/debian/Dockerfile
parent94f7a18c01ab93952e3db95fb404eabd15ee47ce (diff)
downloadbiboumi-16feed7e9e3c215625a62d444d7fa62c2a707c28.tar.gz
biboumi-16feed7e9e3c215625a62d444d7fa62c2a707c28.tar.bz2
biboumi-16feed7e9e3c215625a62d444d7fa62c2a707c28.tar.xz
biboumi-16feed7e9e3c215625a62d444d7fa62c2a707c28.zip
Update the DockerFiles to include openssl
Diffstat (limited to 'docker/biboumi-test/debian/Dockerfile')
-rw-r--r--docker/biboumi-test/debian/Dockerfile6
1 files changed, 5 insertions, 1 deletions
diff --git a/docker/biboumi-test/debian/Dockerfile b/docker/biboumi-test/debian/Dockerfile
index 436cf9a..c6fc586 100644
--- a/docker/biboumi-test/debian/Dockerfile
+++ b/docker/biboumi-test/debian/Dockerfile
@@ -50,13 +50,17 @@ RUN cd slixmpp && python3 setup.py build && python3 setup.py install
RUN useradd tester -m
# Install charybdis, for e2e tests
-RUN apt install -y automake autoconf flex bison libltdl-dev openssl zlib1g-dev
+RUN apt install -y automake autoconf flex bison libltdl-dev openssl zlib1g-dev libssl-dev
RUN apt install -y libtool
RUN git clone https://github.com/charybdis-ircd/charybdis.git && cd charybdis
RUN cd /charybdis && git checkout 4f2b9a4 && sed s/113/1113/ -i /charybdis/authd/providers/ident.c && ./autogen.sh && ./configure --prefix=/home/tester/ircd --bindir=/usr/bin && make -j8 && make install
RUN chown -R tester:tester /home/tester/ircd
RUN rm -rf /charybdis
+RUN yes "" | openssl req -nodes -x509 -newkey rsa:4096 -keyout /home/tester/ircd/etc/ssl.key -out /home/tester/ircd/etc/ssl.pem
+
+RUN apt install -y curl
+
ENV LC_ALL C.UTF-8
WORKDIR /home/tester