summaryrefslogtreecommitdiff
path: root/docker/biboumi-test/Dockerfile
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2016-05-12 10:04:01 +0200
committerlouiz’ <louiz@louiz.org>2016-05-12 11:41:54 +0200
commitce2b8a15f17151c9ecfeebdec205ff2bb9248078 (patch)
tree82ce1536331bd2c5f0435c64672cecb1fa0dcf0f /docker/biboumi-test/Dockerfile
parente8e60b715c574388fc9df3f7a73801de38233679 (diff)
downloadbiboumi-ce2b8a15f17151c9ecfeebdec205ff2bb9248078.tar.gz
biboumi-ce2b8a15f17151c9ecfeebdec205ff2bb9248078.tar.bz2
biboumi-ce2b8a15f17151c9ecfeebdec205ff2bb9248078.tar.xz
biboumi-ce2b8a15f17151c9ecfeebdec205ff2bb9248078.zip
ci: Have two builds: on fedora and on debian
Diffstat (limited to 'docker/biboumi-test/Dockerfile')
-rw-r--r--docker/biboumi-test/Dockerfile64
1 files changed, 0 insertions, 64 deletions
diff --git a/docker/biboumi-test/Dockerfile b/docker/biboumi-test/Dockerfile
deleted file mode 100644
index 704b413..0000000
--- a/docker/biboumi-test/Dockerfile
+++ /dev/null
@@ -1,64 +0,0 @@
-# This Dockerfile creates a docker image suitable to run biboumi’s build and
-# tests. For example, it can be used on with gitlab-ci.
-
-FROM docker.io/fedora:latest
-
-RUN dnf update -y
-
-# Needed to build biboumi
-RUN dnf install -y gcc-c++
-RUN dnf install -y clang
-RUN dnf install -y valgrind
-RUN dnf install -y c-ares-devel
-RUN dnf install -y sqlite-devel
-RUN dnf install -y libuuid-devel
-RUN dnf install -y cmake
-RUN dnf install -y make
-RUN dnf install -y expat-devel
-RUN dnf install -y libidn-devel
-RUN dnf install -y uuid-devel
-RUN dnf install -y systemd-devel
-RUN dnf install -y rubygem-ronn
-
-# Needed to run tests
-RUN dnf install -y git
-RUN dnf install -y fedora-packager python3-lxml
-RUN dnf install -y lcov
-
-# To be able to create the RPM
-RUN dnf install -y rpmdevtools
-
-# Install botan
-RUN git clone https://github.com/randombit/botan.git
-RUN cd botan && git checkout 1.11.28 && ./configure.py --prefix=/usr && make -j8 && make install
-RUN rm -rf /botan
-
-# Install litesql
-RUN git clone git://git.louiz.org/litesql
-RUN mkdir /litesql/build && cd /litesql/build && cmake .. -DCMAKE_INSTALL_PREFIX=/usr && make -j8
-RUN cd /litesql/build && make install
-RUN rm -rf /litesql
-
-RUN ldconfig
-
-# Install slixmpp, for e2e tests
-RUN git clone git://git.louiz.org/slixmpp
-RUN pip3 install pyasn1
-RUN dnf install -y python3-devel
-RUN cd slixmpp && python3 setup.py build && python3 setup.py install
-
-RUN useradd tester
-
-# Install charybdis, for e2e tests
-RUN dnf install -y automake autoconf flex flex-devel bison libtool-ltdl-devel openssl-devel
-RUN dnf install -y libtool
-RUN git clone https://github.com/charybdis-ircd/charybdis.git && cd charybdis
-RUN cd /charybdis && ./autogen.sh && ./configure --prefix=/home/tester/ircd --bindir=/usr/bin && make -j8 && make install
-RUN chown -R tester:tester /home/tester/ircd
-RUN rm -rf /charybdis
-
-RUN su - tester -c "echo export LANG=fr_FR.utf-8 >> /home/tester/.bashrc"
-
-WORKDIR /home/tester
-USER tester
-