summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2016-12-21 21:47:01 +0100
committerJonas Smedegaard <dr@jones.dk>2016-12-21 21:47:01 +0100
commit54fdd90fa343f2fd00a5ed416e7323db3cd07f4b (patch)
tree38bc560b72a8d55db7066e8b2cf10f09b5255097 /debian/rules
parent50a5a9ae96f090df5481d4f178be9f5910c922cb (diff)
downloadbiboumi-54fdd90fa343f2fd00a5ed416e7323db3cd07f4b.tar.gz
biboumi-54fdd90fa343f2fd00a5ed416e7323db3cd07f4b.tar.bz2
biboumi-54fdd90fa343f2fd00a5ed416e7323db3cd07f4b.tar.xz
biboumi-54fdd90fa343f2fd00a5ed416e7323db3cd07f4b.zip
Install documentation and example files.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 6 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 38d82c1..c80ba2e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -22,8 +22,14 @@ include /usr/share/cdbs/1/rules/utils.mk
include /usr/share/cdbs/1/class/cmake.mk
+pkg = $(DEB_SOURCE_PACKAGE)
+
dev-deps = expat1 idn11 systemd c-ares botan1.10
CDBS_BUILD_DEPENDS += , cmake, catch, uuid-dev, pandoc
CDBS_BUILD_DEPENDS += , $(patsubst %,$(comma) lib%-dev,$(dev-deps))
DEB_MAKE_CHECK_TARGET = check
+
+DEB_INSTALL_CHANGELOGS_ALL += CHANGELOG.rst
+DEB_INSTALL_DOCS_$(pkg) += README.rst CONTRIBUTING.rst
+DEB_INSTALL_EXAMPLES_$(pkg) = doc/example.conf