summaryrefslogtreecommitdiff
path: root/debian/copyright-check
diff options
context:
space:
mode:
authorJonas Smedegaard <dr@jones.dk>2017-05-21 11:19:03 +0200
committerJonas Smedegaard <dr@jones.dk>2017-05-21 11:36:59 +0200
commitd653efcc3dc6db803a838c78a821b1cef9e618d2 (patch)
tree2b78a4224887850f0d4e59e65899bdcc6307a58e /debian/copyright-check
parentb635a2d52df53ab2cfc7dd248aaef7c90cc7ecc7 (diff)
downloadbiboumi-d653efcc3dc6db803a838c78a821b1cef9e618d2.tar.gz
biboumi-d653efcc3dc6db803a838c78a821b1cef9e618d2.tar.bz2
biboumi-d653efcc3dc6db803a838c78a821b1cef9e618d2.tar.xz
biboumi-d653efcc3dc6db803a838c78a821b1cef9e618d2.zip
Modernize cdbs: Do copyright-check in maintainer script (not during build).
Diffstat (limited to 'debian/copyright-check')
-rwxr-xr-xdebian/copyright-check27
1 files changed, 27 insertions, 0 deletions
diff --git a/debian/copyright-check b/debian/copyright-check
new file mode 100755
index 0000000..1f715d9
--- /dev/null
+++ b/debian/copyright-check
@@ -0,0 +1,27 @@
+#!/bin/sh
+# Copyright © 2016-2017 Jonas Smedegaard <dr@jones.dk>
+# Description: helper script to update copyright_hints
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+set -eu
+
+# extract metadata from binary media files
+#export DEB_COPYRIGHT_EXTRACT_EXTS=png
+
+make -f /usr/share/cdbs/1/rules/utils.mk pre-build || true
+make -f /usr/share/cdbs/1/rules/utils.mk clean DEB_COPYRIGHT_CHECK_STRICT=1
+
+# unconditionally merge changes - safe to do with git-tracked package
+[ ! -f debian/copyright_newhints ] || mv -f debian/copyright_newhints debian/copyright_hints