summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2014-07-15 15:44:19 +0200
committerFlorent Le Coz <louiz@louiz.org>2014-07-15 15:44:19 +0200
commitb94247813bfdcb95b2b3cde9a7d27f90254f2a2f (patch)
tree144f4aa44ff5c8ac45cfe56ec4c27c0a41471712 /CMakeLists.txt
parent11a31db2d5bcc158bb8902e74f192dbc82827f53 (diff)
downloadbiboumi-b94247813bfdcb95b2b3cde9a7d27f90254f2a2f.tar.gz
biboumi-b94247813bfdcb95b2b3cde9a7d27f90254f2a2f.tar.bz2
biboumi-b94247813bfdcb95b2b3cde9a7d27f90254f2a2f.tar.xz
biboumi-b94247813bfdcb95b2b3cde9a7d27f90254f2a2f.zip
Provide WITHOUT_BOTAN and WITHOUT_SYSTEMD cmake flags
Use them to build without linking to them, even if they are on your system
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f68e7db..14c002c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,8 +21,12 @@ find_package(EXPAT REQUIRED)
find_package(Iconv REQUIRED)
find_package(Libuuid REQUIRED)
find_package(Libidn)
-find_package(SystemdDaemon)
-find_package(Botan)
+if(NOT WITHOUT_SYSTEMD)
+ find_package(SystemdDaemon)
+endif()
+if(NOT WITHOUT_BOTAN)
+ find_package(Botan)
+endif()
#
## Get the software version