summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2014-01-14 21:45:56 +0100
committerFlorent Le Coz <louiz@louiz.org>2014-01-14 21:45:56 +0100
commitb71547a32b9beefbe24465a5ba092d2f9b3b04e5 (patch)
tree6356546dd99aa6f87c00aef24387b922fa36df05 /CMakeLists.txt
parentd1c6d64546f5b139ec7946696602be5fe9fca66e (diff)
downloadbiboumi-b71547a32b9beefbe24465a5ba092d2f9b3b04e5.tar.gz
biboumi-b71547a32b9beefbe24465a5ba092d2f9b3b04e5.tar.bz2
biboumi-b71547a32b9beefbe24465a5ba092d2f9b3b04e5.tar.xz
biboumi-b71547a32b9beefbe24465a5ba092d2f9b3b04e5.zip
Fix the build system to correctly include config.h
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 433b965..222c609 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,6 +21,8 @@ include(FindEXPAT)
find_package(EXPAT REQUIRED)
find_package(Libidn)
+# To be able to include the config.h file generated by cmake
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
include_directories("src/")
include_directories(${EXPAT_INCLUDE_DIRS})
include_directories(${ICONV_INCLUDE_DIRS})
@@ -123,4 +125,4 @@ target_link_libraries(test
config
logger)
-configure_file(config.h.cmake src/config.h)
+configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h) \ No newline at end of file