summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2014-06-26 13:53:06 +0200
committerFlorent Le Coz <louiz@louiz.org>2014-06-30 01:02:59 +0200
commita165e5924012c82d2598495d962597ae896e9cf7 (patch)
treede61142bf571fc89bdc4f4c3a7ff63ac301e46aa /CMakeLists.txt
parent48ed47207cabe98ad7720048f03b7b09f5cf24cb (diff)
downloadbiboumi-a165e5924012c82d2598495d962597ae896e9cf7.tar.gz
biboumi-a165e5924012c82d2598495d962597ae896e9cf7.tar.bz2
biboumi-a165e5924012c82d2598495d962597ae896e9cf7.tar.xz
biboumi-a165e5924012c82d2598495d962597ae896e9cf7.zip
Fix some cmake issues
fix #2551
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 6 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a33fffe..70ead76 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -173,15 +173,13 @@ target_link_libraries(${PROJECT_NAME}
if(SYSTEMDDAEMON_FOUND)
target_link_libraries(xmpp ${SYSTEMDDAEMON_LIBRARIES})
endif()
-if(WITH_DOC)
- add_dependencies(${PROJECT_NAME} doc)
-endif()
+
#
## Tests
#
-
-add_executable(test_suite src/test.cpp)
+add_executable(test_suite EXCLUDE_FROM_ALL
+ src/test.cpp)
target_link_libraries(test_suite
xmpp
irc
@@ -190,6 +188,7 @@ target_link_libraries(test_suite
config
logger)
+
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/src/config.h)
#
@@ -198,7 +197,7 @@ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/src/config.h.cmake ${CMAKE_CURRENT_BI
install(TARGETS ${PROJECT_NAME}
RUNTIME DESTINATION bin)
if(WITH_DOC)
- install(FILES ${MAN_PAGE} DESTINATION man/man1)
+ install(FILES ${MAN_PAGE} DESTINATION share/man/man1 OPTIONAL)
endif()
#
@@ -208,4 +207,4 @@ endif()
add_custom_target(dist
COMMAND git archive --prefix=${ARCHIVE_NAME}/ --format=tar HEAD
| xz > ${CMAKE_CURRENT_BINARY_DIR}/${ARCHIVE_NAME}.tar.xz
- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}) \ No newline at end of file
+ WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})