summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2016-04-22 10:44:29 +0200
committerlouiz’ <louiz@louiz.org>2016-04-22 10:49:07 +0200
commit747f04ee6d104f466014a0b0e810ac9f855fa547 (patch)
tree50e2fb6efd41d83971b8497a79fefeb7382df162 /CMakeLists.txt
parent3119ec72f32abf0dbd1edf7fc2f302fc9dd60ced (diff)
downloadbiboumi-747f04ee6d104f466014a0b0e810ac9f855fa547.tar.gz
biboumi-747f04ee6d104f466014a0b0e810ac9f855fa547.tar.bz2
biboumi-747f04ee6d104f466014a0b0e810ac9f855fa547.tar.xz
biboumi-747f04ee6d104f466014a0b0e810ac9f855fa547.zip
Move the e2e tests out of make check
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ec6ae73..b3321cd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -195,8 +195,10 @@ if(NOT EXISTS ${CMAKE_SOURCE_DIR}/tests/catch.hpp)
add_dependencies(test_suite catch)
endif()
add_custom_target(check COMMAND "test_suite"
- COMMAND "python3" "${CMAKE_CURRENT_SOURCE_DIR}/tests/end_to_end/"
DEPENDS test_suite biboumi)
+add_custom_target(e2e COMMAND "python3" "${CMAKE_CURRENT_SOURCE_DIR}/tests/end_to_end/"
+ DEPENDS biboumi)
+
#
## Code coverage