summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2016-04-22 10:36:14 +0200
committerlouiz’ <louiz@louiz.org>2016-04-22 10:49:07 +0200
commit3119ec72f32abf0dbd1edf7fc2f302fc9dd60ced (patch)
treeeeacbf9293407cf7fe1c223e8373165fee484af6 /CMakeLists.txt
parent327c821f4630b283e08a0b0875a6e7073af2423d (diff)
downloadbiboumi-3119ec72f32abf0dbd1edf7fc2f302fc9dd60ced.tar.gz
biboumi-3119ec72f32abf0dbd1edf7fc2f302fc9dd60ced.tar.bz2
biboumi-3119ec72f32abf0dbd1edf7fc2f302fc9dd60ced.tar.xz
biboumi-3119ec72f32abf0dbd1edf7fc2f302fc9dd60ced.zip
Force LANG to en_US when generating biboumi.spec (fixes the date format)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8bfc2e2..ec6ae73 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -265,7 +265,10 @@ else()
endif()
configure_file(unit/biboumi.service.cmake biboumi.service)
+# The date MUST be in english format
+set(ENV{LANG} "en_US.utf-8")
execute_process(COMMAND "date" "+%a %b %d %Y" OUTPUT_VARIABLE RPM_DATE
OUTPUT_STRIP_TRAILING_WHITESPACE)
+unset(ENV{LANG})
configure_file(packaging/biboumi.spec.cmake biboumi.spec)