summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2015-02-27 12:40:50 +0100
committerFlorent Le Coz <louiz@louiz.org>2015-02-27 12:40:50 +0100
commite6569a1090be063f34624474f0d4578f37a169ae (patch)
tree6413317e351bfb91dd777b851a7c4c004f7b66c8 /CMakeLists.txt
parent0ec82c104ded01a44ed36d20e25220fa41887fd0 (diff)
downloadbiboumi-e6569a1090be063f34624474f0d4578f37a169ae.tar.gz
biboumi-e6569a1090be063f34624474f0d4578f37a169ae.tar.bz2
biboumi-e6569a1090be063f34624474f0d4578f37a169ae.tar.xz
biboumi-e6569a1090be063f34624474f0d4578f37a169ae.zip
Only use include_directory() if the directory path is defined
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 12 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 808d9e4..a516589 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,10 +74,18 @@ include_directories(${ICONV_INCLUDE_DIRS})
include_directories(${LIBUUID_INCLUDE_DIRS})
# If they are found in louloulibs CMakeLists.txt, we inherite these values
-include_directories(${LIBIDN_INCLUDE_DIRS})
-include_directories(${SYSTEMD_INCLUDE_DIRS})
-include_directories(SYSTEM ${BOTAN_INCLUDE_DIRS})
-include_directories(${CARES_INCLUDE_DIRS})
+if(LIBIDN_FOUND)
+ include_directories(${LIBIDN_INCLUDE_DIRS})
+endif()
+if(SYSTEMD_FOUND)
+ include_directories(${SYSTEMD_INCLUDE_DIRS})
+endif()
+if(BOTAN_FOUND)
+ include_directories(SYSTEM ${BOTAN_INCLUDE_DIRS})
+endif()
+if(CARES_FOUND)
+ include_directories(${CARES_INCLUDE_DIRS})
+endif()
#
## irclib