summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2013-11-09 06:01:47 +0100
committerFlorent Le Coz <louiz@louiz.org>2013-11-09 06:01:47 +0100
commitccebe901d7d76dfddc082d994efa54ef2aefee57 (patch)
tree97a542cce7c3c3185553859f679dc074f8f0286f /CMakeLists.txt
parenta418b6ed5d70f0e61e71bb1adce2a693ade89e30 (diff)
downloadbiboumi-ccebe901d7d76dfddc082d994efa54ef2aefee57.tar.gz
biboumi-ccebe901d7d76dfddc082d994efa54ef2aefee57.tar.bz2
biboumi-ccebe901d7d76dfddc082d994efa54ef2aefee57.tar.xz
biboumi-ccebe901d7d76dfddc082d994efa54ef2aefee57.zip
Check UTF-8 encoding, and convert strings to UTF-8
Handle conversion errors properly by inserting � instead. Add a binary header to provide portable way to write binary literals (I like them) Also add a test file. ref #2404
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 21 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bff724c..bd8ca76 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,6 +20,13 @@ include_directories("src/")
include_directories(SYSTEM ${CRYPTO++_INCLUDE_DIR})
#
+## utils
+#
+file(GLOB source_utils
+ src/utils/*.[hc]pp)
+add_library(utils STATIC ${source_utils})
+
+#
## network
#
file(GLOB source_network
@@ -32,7 +39,7 @@ add_library(network STATIC ${source_network})
file(GLOB source_irc
src/irc/*.[hc]pp)
add_library(irc STATIC ${source_irc})
-target_link_libraries(irc network)
+target_link_libraries(irc network utils)
#
## xmpplib
@@ -40,7 +47,7 @@ target_link_libraries(irc network)
file(GLOB source_xmpp
src/xmpp/*.[hc]pp)
add_library(xmpp STATIC ${source_xmpp})
-target_link_libraries(xmpp bridge network ${CRYPTO++_LIBRARIES} expatpp)
+target_link_libraries(xmpp bridge network utils ${CRYPTO++_LIBRARIES} expatpp)
#
## bridge
@@ -54,4 +61,15 @@ add_executable(${PROJECT_NAME} src/main.cpp)
target_link_libraries(${PROJECT_NAME}
xmpp
irc
- bridge) \ No newline at end of file
+ bridge)
+
+#
+## Tests
+#
+
+add_executable(test src/test.cpp)
+target_link_libraries(test
+ xmpp
+ irc
+ bridge
+ utils)