summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2013-12-08 20:14:12 +0100
committerFlorent Le Coz <louiz@louiz.org>2013-12-08 20:14:12 +0100
commitb11126a19dbaadf4c32fb8dbec22754ad0712c26 (patch)
tree140a9c33a264adfb4eee7a0e2add0b6c5ec1671c /CMakeLists.txt
parentcb718def0cb51aac4c2125e3864522740fcb2573 (diff)
downloadbiboumi-b11126a19dbaadf4c32fb8dbec22754ad0712c26.tar.gz
biboumi-b11126a19dbaadf4c32fb8dbec22754ad0712c26.tar.bz2
biboumi-b11126a19dbaadf4c32fb8dbec22754ad0712c26.tar.xz
biboumi-b11126a19dbaadf4c32fb8dbec22754ad0712c26.zip
Provide a JID for IRC users, and add a stringprep dependency for this
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8a8ae9c..ac93ff1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,6 +20,7 @@ find_package(Cryptopp REQUIRED)
find_package(Iconv REQUIRED)
include(FindEXPAT)
find_package(EXPAT REQUIRED)
+find_package(Libidn)
include_directories("src/")
include_directories(${EXPAT_INCLUDE_DIRS})
@@ -28,6 +29,12 @@ include_directories(${ICONV_INCLUDE_DIRS})
# coming from these headers.
include_directories(SYSTEM ${CRYPTO++_INCLUDE_DIRS})
+if(LIBIDN_FOUND)
+ include_directories(${LIBIDN_INCLUDE_DIRS})
+else()
+ message("Building without stringprep support.")
+endif()
+
set(POLLER "POLL" CACHE STRING
"Choose the poller between POLL and EPOLL (Linux-only)")
if((NOT ${POLLER} MATCHES "POLL") AND
@@ -35,6 +42,7 @@ if((NOT ${POLLER} MATCHES "POLL") AND
message(FATAL_ERROR "POLLER must be either POLL or EPOLL")
endif()
+
#
## utils
#
@@ -83,6 +91,9 @@ file(GLOB source_xmpp
add_library(xmpp STATIC ${source_xmpp})
target_link_libraries(xmpp bridge network utils logger
${CRYPTO++_LIBRARIES} ${EXPAT_LIBRARIES} pthread)
+if(LIBIDN_FOUND)
+ target_link_libraries(xmpp ${LIBIDN_LIBRARIES})
+endif()
#
## bridge