summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2013-12-03 19:10:44 +0100
committerFlorent Le Coz <louiz@louiz.org>2013-12-03 19:15:37 +0100
commita4c845ab6c54172ea305f33734c83238c75d421a (patch)
tree3ed5393e993f0e9b72fabd9413453fadbfe9a9a9 /CMakeLists.txt
parent2662ed89e2cd41477582140e482f1ddbbfdb235e (diff)
downloadbiboumi-a4c845ab6c54172ea305f33734c83238c75d421a.tar.gz
biboumi-a4c845ab6c54172ea305f33734c83238c75d421a.tar.bz2
biboumi-a4c845ab6c54172ea305f33734c83238c75d421a.tar.xz
biboumi-a4c845ab6c54172ea305f33734c83238c75d421a.zip
Use the logger everywhere
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 51253cc..ea51db7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -64,6 +64,7 @@ target_link_libraries(logger config)
file(GLOB source_network
src/network/*.[hc]pp)
add_library(network STATIC ${source_network})
+target_link_libraries(network logger)
#
## irclib
@@ -71,7 +72,7 @@ add_library(network STATIC ${source_network})
file(GLOB source_irc
src/irc/*.[hc]pp)
add_library(irc STATIC ${source_irc})
-target_link_libraries(irc network utils)
+target_link_libraries(irc network utils logger)
#
## xmpplib
@@ -79,7 +80,7 @@ target_link_libraries(irc network utils)
file(GLOB source_xmpp
src/xmpp/*.[hc]pp)
add_library(xmpp STATIC ${source_xmpp})
-target_link_libraries(xmpp bridge network utils
+target_link_libraries(xmpp bridge network utils logger
${CRYPTO++_LIBRARIES} ${EXPAT_LIBRARIES} pthread)
#
@@ -88,7 +89,7 @@ target_link_libraries(xmpp bridge network utils
file(GLOB source_bridge
src/bridge/*.[hc]pp)
add_library(bridge STATIC ${source_bridge})
-target_link_libraries(bridge xmpp irc utils)
+target_link_libraries(bridge xmpp irc utils logger)
#
## Main executable