summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2014-01-12 04:12:27 +0100
committerFlorent Le Coz <louiz@louiz.org>2014-01-13 20:11:36 +0100
commit48b4f7b83f9f8e6d89d56f5e24f0ed1d7c4676a1 (patch)
tree0d8b34dd628d2c5d74a3c39263d2a0e6d6be0d40 /CMakeLists.txt
parentfef9c8193ddf8cdf81978874be788af9441e2286 (diff)
downloadbiboumi-48b4f7b83f9f8e6d89d56f5e24f0ed1d7c4676a1.tar.gz
biboumi-48b4f7b83f9f8e6d89d56f5e24f0ed1d7c4676a1.tar.bz2
biboumi-48b4f7b83f9f8e6d89d56f5e24f0ed1d7c4676a1.tar.xz
biboumi-48b4f7b83f9f8e6d89d56f5e24f0ed1d7c4676a1.zip
Remove cryptopp dependency, directly include a simple sha1 implementation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ac93ff1..433b965 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,7 +16,6 @@ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -D__FILENAME__='\"$(subst ${CMAKE_SOURCE
## Look for external libraries
#
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
-find_package(Cryptopp REQUIRED)
find_package(Iconv REQUIRED)
include(FindEXPAT)
find_package(EXPAT REQUIRED)
@@ -25,9 +24,6 @@ find_package(Libidn)
include_directories("src/")
include_directories(${EXPAT_INCLUDE_DIRS})
include_directories(${ICONV_INCLUDE_DIRS})
-# the SYSTEM flag tells the compiler that we don't care about warnings
-# coming from these headers.
-include_directories(SYSTEM ${CRYPTO++_INCLUDE_DIRS})
if(LIBIDN_FOUND)
include_directories(${LIBIDN_INCLUDE_DIRS})
@@ -90,7 +86,7 @@ file(GLOB source_xmpp
src/xmpp/*.[hc]pp)
add_library(xmpp STATIC ${source_xmpp})
target_link_libraries(xmpp bridge network utils logger
- ${CRYPTO++_LIBRARIES} ${EXPAT_LIBRARIES} pthread)
+ ${EXPAT_LIBRARIES} pthread)
if(LIBIDN_FOUND)
target_link_libraries(xmpp ${LIBIDN_LIBRARIES})
endif()