summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2018-06-08 19:32:52 +0200
committerlouiz’ <louiz@louiz.org>2018-06-08 19:32:52 +0200
commit8afeb0ca92ff42227aee379c774fe9546a7461ba (patch)
tree8d115c5c38af0391504d6e51e9635f9ec8819fa3 /CMakeLists.txt
parent1157264940053a07c832ba018bc0d6bd6e5866ff (diff)
downloadbiboumi-8afeb0ca92ff42227aee379c774fe9546a7461ba.tar.gz
biboumi-8afeb0ca92ff42227aee379c774fe9546a7461ba.tar.bz2
biboumi-8afeb0ca92ff42227aee379c774fe9546a7461ba.tar.xz
biboumi-8afeb0ca92ff42227aee379c774fe9546a7461ba.zip
Ok, dirty workaround for cmake < 3.11.2test_cmake3_11_2
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1d57a0b..1fe065f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -219,7 +219,11 @@ if(SQLITE3_FOUND OR PQ_FOUND)
endif()
set(USE_DATABASE TRUE)
else()
- add_library(database OBJECT "")
+ if(${CMAKE_VERSION} VERSION_LESS "3.11.2")
+ add_library(database OBJECT "")
+ else()
+ add_library(database OBJECT)
+ endif()
endif()
#