summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2017-05-21 12:02:23 +0200
committerlouiz’ <louiz@louiz.org>2017-05-21 12:02:23 +0200
commit2a637bee0a903423d1e7438ec8715fc94432f511 (patch)
tree0ad3aa6719f62dfe60fac5ea5cf004fe129136ef /CMakeLists.txt
parent0ee533256d13c3a19c45db376fa872ebe619bf21 (diff)
downloadbiboumi-2a637bee0a903423d1e7438ec8715fc94432f511.tar.gz
biboumi-2a637bee0a903423d1e7438ec8715fc94432f511.tar.bz2
biboumi-2a637bee0a903423d1e7438ec8715fc94432f511.tar.xz
biboumi-2a637bee0a903423d1e7438ec8715fc94432f511.zip
Do not install biboumi.cfg in /etc/biboumi/
Because it would overwrite the user file when installing a new version. And it’s basically useless anyway, because if the file doesn’t exist at all, biboumi will write an helpful message on stderr, telling the user to create the config file.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4cc9898..86c309e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -342,7 +342,6 @@ add_custom_target(everything DEPENDS test_suite biboumi)
install(TARGETS ${PROJECT_NAME} RUNTIME DESTINATION bin)
install(FILES ${MAN_PAGE} DESTINATION share/man/man1 OPTIONAL COMPONENT documentation)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/biboumi.service DESTINATION lib/systemd/system COMPONENT init)
-install(FILES conf/biboumi.cfg DESTINATION /etc/biboumi COMPONENT configuration)
file(GLOB policy_files conf/*policy.txt)
install(FILES ${policy_files} DESTINATION /etc/biboumi COMPONENT configuration)