summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2018-04-28 13:37:46 +0200
committerlouiz’ <louiz@louiz.org>2018-04-28 13:57:17 +0200
commitf481e2f194d60e9be39ca44ede8d46717937451e (patch)
treeae743f82df276e5ee052f0508a838439164c2f6b /CMakeLists.txt
parent97c8e2fed3b510d8048a386230b480c3044153d4 (diff)
downloadbiboumi-f481e2f194d60e9be39ca44ede8d46717937451e.tar.gz
biboumi-f481e2f194d60e9be39ca44ede8d46717937451e.tar.bz2
biboumi-f481e2f194d60e9be39ca44ede8d46717937451e.tar.xz
biboumi-f481e2f194d60e9be39ca44ede8d46717937451e.zip
Fix the test_suite by using catch’s single_include directory
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5d31900..1fe8010 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -308,7 +308,7 @@ set_target_properties(catch PROPERTIES EXCLUDE_FROM_ALL TRUE)
ExternalProject_Get_Property(catch SOURCE_DIR)
if(NOT EXISTS ${CMAKE_SOURCE_DIR}/tests/catch.hpp)
target_include_directories(test_suite
- PUBLIC "${SOURCE_DIR}/include/"
+ PUBLIC "${SOURCE_DIR}/single_include/"
)
add_dependencies(test_suite catch)
endif()