summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2017-04-13 00:19:17 +0200
committerlouiz’ <louiz@louiz.org>2017-04-13 00:19:17 +0200
commitdc5ad49b4011bb637373c6088efaf219fed4a016 (patch)
tree6f0bddbf0276e4446beb9229c61f310cbce5a834 /CMakeLists.txt
parent3a8203c366d46ec2937a601868f5e2ed591c923e (diff)
downloadbiboumi-dc5ad49b4011bb637373c6088efaf219fed4a016.tar.gz
biboumi-dc5ad49b4011bb637373c6088efaf219fed4a016.tar.bz2
biboumi-dc5ad49b4011bb637373c6088efaf219fed4a016.tar.xz
biboumi-dc5ad49b4011bb637373c6088efaf219fed4a016.zip
Avoid building test_suite when we make install
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 581782e..9458f00 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -228,6 +228,7 @@ add_executable(test_suite ${source_tests}
$<TARGET_OBJECTS:irc>
$<TARGET_OBJECTS:identd>
$<TARGET_OBJECTS:database>)
+set_target_properties(test_suite PROPERTIES EXCLUDE_FROM_ALL TRUE)
#
## Link the executables with their libraries
@@ -298,8 +299,10 @@ endif()
#
add_custom_target(check COMMAND "test_suite"
DEPENDS test_suite biboumi)
+set_target_properties(check PROPERTIES EXCLUDE_FROM_ALL TRUE)
add_custom_target(e2e COMMAND "python3" "${CMAKE_CURRENT_SOURCE_DIR}/tests/end_to_end/"
DEPENDS biboumi)
+set_target_properties(e2e PROPERTIES EXCLUDE_FROM_ALL TRUE)
add_custom_target(e2e_valgrind COMMAND "E2E_BIBOUMI_SUPP_DIR=${CMAKE_CURRENT_SOURCE_DIR}/tests/end_to_end/" "E2E_BIBOUMI_VALGRIND=1" "python3" "${CMAKE_CURRENT_SOURCE_DIR}/tests/end_to_end/"
DEPENDS biboumi)
if(CMAKE_BUILD_TYPE MATCHES Debug)
@@ -323,6 +326,7 @@ if(CMAKE_BUILD_TYPE MATCHES Debug)
WORKING_DIRECTORY ${CMAKE_BINARY_DIR}
)
endif()
+add_custom_target(everything DEPENDS test_suite biboumi)
#
## Install target