summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2016-09-28 19:48:00 +0200
committerlouiz’ <louiz@louiz.org>2016-09-28 19:48:00 +0200
commitdaa7ea04a447d4c67a225eb116c0befc2866ea66 (patch)
treeb4b0444dd2a55439860441006797cb6c2d8df8e2 /CMakeLists.txt
parent2922c68e8315190bfc1aa81fbf4959dbb052be3b (diff)
downloadbiboumi-daa7ea04a447d4c67a225eb116c0befc2866ea66.tar.gz
biboumi-daa7ea04a447d4c67a225eb116c0befc2866ea66.tar.bz2
biboumi-daa7ea04a447d4c67a225eb116c0befc2866ea66.tar.xz
biboumi-daa7ea04a447d4c67a225eb116c0befc2866ea66.zip
Add coverage_e2e, which runs e2e, and regenerate a global coverage report
This coverage is probably more useful than the other one, because it’s not really reasonable to try to cover everything with simple units test (e.g. on network code etc). However, we should strive to have 100% coverage with our e2e tests.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 252f437..35f11ee 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -232,6 +232,10 @@ if(CMAKE_BUILD_TYPE MATCHES Debug)
test_suite
coverage
)
+ SETUP_TARGET_FOR_COVERAGE(coverage_e2e
+ make
+ coverage_e2e
+ e2e)
endif()
#