summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2018-06-08 20:03:55 +0200
committerlouiz’ <louiz@louiz.org>2018-06-08 20:03:55 +0200
commit72c3324cf38f0173676f123ed4d8e3418c66f14b (patch)
treef43b809d2aae4e12818f6756fdaed74bcd3028d1 /CMakeLists.txt
parente3730c5a40a9d4a098ae9fb9a3bd867803007da1 (diff)
downloadbiboumi-72c3324cf38f0173676f123ed4d8e3418c66f14b.tar.gz
biboumi-72c3324cf38f0173676f123ed4d8e3418c66f14b.tar.bz2
biboumi-72c3324cf38f0173676f123ed4d8e3418c66f14b.tar.xz
biboumi-72c3324cf38f0173676f123ed4d8e3418c66f14b.zip
Correctly use target_sources instead of target_link_libraries
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7539886..c6ac616 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -249,8 +249,8 @@ add_executable(test_suite ${source_tests}
$<TARGET_OBJECTS:identd>)
set_target_properties(test_suite PROPERTIES EXCLUDE_FROM_ALL TRUE)
if(USE_DATABASE)
- target_link_libraries(${PROJECT_NAME} $<TARGET_OBJECTS:database>)
- target_link_libraries(test_suite $<TARGET_OBJECTS:database>)
+ target_sources(${PROJECT_NAME} PRIVATE $<TARGET_OBJECTS:database>)
+ target_sources(test_suite PRIVATE $<TARGET_OBJECTS:database>)
endif()
#