summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2013-11-06 20:51:05 +0100
committerFlorent Le Coz <louiz@louiz.org>2013-11-06 21:01:18 +0100
commitbf7b05ef72bbdac97704d262ddfe418908267535 (patch)
treeb23b3a5a5d469c47c37422559be76ee34238649a /CMakeLists.txt
parentdea7f60fa1ae6a46228daa36bcb3fec1a6c6ffc3 (diff)
downloadbiboumi-bf7b05ef72bbdac97704d262ddfe418908267535.tar.gz
biboumi-bf7b05ef72bbdac97704d262ddfe418908267535.tar.bz2
biboumi-bf7b05ef72bbdac97704d262ddfe418908267535.tar.xz
biboumi-bf7b05ef72bbdac97704d262ddfe418908267535.zip
Implement the Bridge class to translate between the two protocols
Add all useful classes as well: Jid, Iid, IrcChannel, IrcUser etc to properly keep the informations about what we receive from the IRC server. Only handle the MUC join stanza, and send the list of users in the IRC channel to the XMPP user, and the IRC channel’s topic, for now.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 12 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 363eb79..bff724c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,7 +32,7 @@ add_library(network STATIC ${source_network})
file(GLOB source_irc
src/irc/*.[hc]pp)
add_library(irc STATIC ${source_irc})
-target_link_libraries(irc network ${CRYPTO++_LIBRARIES} expatpp)
+target_link_libraries(irc network)
#
## xmpplib
@@ -40,9 +40,18 @@ target_link_libraries(irc network ${CRYPTO++_LIBRARIES} expatpp)
file(GLOB source_xmpp
src/xmpp/*.[hc]pp)
add_library(xmpp STATIC ${source_xmpp})
-target_link_libraries(xmpp network )
+target_link_libraries(xmpp bridge network ${CRYPTO++_LIBRARIES} expatpp)
+
+#
+## bridge
+#
+file(GLOB source_bridge
+ src/bridge/*.[hc]pp)
+add_library(bridge STATIC ${source_bridge})
+target_link_libraries(bridge xmpp irc)
add_executable(${PROJECT_NAME} src/main.cpp)
target_link_libraries(${PROJECT_NAME}
xmpp
- irc) \ No newline at end of file
+ irc
+ bridge) \ No newline at end of file