summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2015-02-27 12:46:22 +0100
committerFlorent Le Coz <louiz@louiz.org>2015-02-27 12:46:22 +0100
commitb3503bf11297a7982bf9e9008b408e3bf8121224 (patch)
tree15b0bdb5e8ea94cd533d11773682d9f56d0ed0cd /CMakeLists.txt
parente6569a1090be063f34624474f0d4578f37a169ae (diff)
downloadbiboumi-b3503bf11297a7982bf9e9008b408e3bf8121224.tar.gz
biboumi-b3503bf11297a7982bf9e9008b408e3bf8121224.tar.bz2
biboumi-b3503bf11297a7982bf9e9008b408e3bf8121224.tar.xz
biboumi-b3503bf11297a7982bf9e9008b408e3bf8121224.zip
Also check if the louloulibs/CMakeLists.txt file is missing
Because apparently when cloning a repository with submodules, git creates empty sub-directories
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a516589..9d9f073 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,8 +63,10 @@ if(RONN_EXECUTABLE)
add_custom_target(doc DEPENDS ${MAN_PAGE})
endif()
-if(NOT IS_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/louloulibs")
- message(FATAL_ERROR "louloulibs/ directory not found. Make sure you fetched the submodules with 'git submodule init && git submodule update'")
+if(NOT IS_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/louloulibs" OR
+ NOT EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/loulou/CMakeLists.txt")
+ message(FATAL_ERROR "louloulibs/ not found or empty. Make sure you fetched
+ the submodules with 'git submodule init && git submodule update'")
endif()
add_subdirectory("louloulibs")
include_directories("louloulibs")