summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2015-09-23 18:24:06 +0200
committerFlorent Le Coz <louiz@louiz.org>2015-09-23 18:47:29 +0200
commitf904d57940699e332f75a77062912431c6e51188 (patch)
tree6e3dc737fcbf77344fadb88d015b80e603b70589 /CMakeLists.txt
parentf6d9b7d7a1d670b3b3d2bd1ca831de8578de6206 (diff)
downloadbiboumi-f904d57940699e332f75a77062912431c6e51188.tar.gz
biboumi-f904d57940699e332f75a77062912431c6e51188.tar.bz2
biboumi-f904d57940699e332f75a77062912431c6e51188.tar.xz
biboumi-f904d57940699e332f75a77062912431c6e51188.zip
Provide username and realname IRC server options
Used in the USER command when connecting to the IRC server, instead of the first nick. fix #3028
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 16 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1bad544..e9560cc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,7 +43,8 @@ endif()
set(SOFTWARE_VERSION
${${PROJECT_NAME}_VERSION_MAJOR}.${${PROJECT_NAME}_VERSION_MINOR}${${PROJECT_NAME}_VERSION_SUFFIX})
-# To be able to include the config.h file generated by cmake
+include(CheckFunctionExists)
+check_function_exists(ppoll HAVE_PPOLL_FUNCTION)
# To be able to include the config.h and other files generated by cmake
include_directories("${CMAKE_CURRENT_BINARY_DIR}/src/")
@@ -121,6 +122,7 @@ target_link_libraries(xmpp xmpplib bridge network utils logger)
if(USE_DATABASE)
target_link_libraries(xmpp database)
endif()
+
#
## bridge
#
@@ -181,4 +183,17 @@ add_custom_target(dist
| xz > ${CMAKE_CURRENT_BINARY_DIR}/${ARCHIVE_NAME}.tar.xz
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
+if(BOTAN_FOUND)
+ set(STR_WITH_BOTAN "Botan: yes")
+else()
+ set(STR_WITH_BOTAN "Botan: no")
+endif()
+if(CARES_FOUND)
+ set(STR_WITH_CARES "c-ares: yes")
+else()
+ set(STR_WITH_CARES "c-ares: no")
+endif()
+add_custom_target(PrintBuildParameters ALL
+ ${CMAKE_COMMAND} -E cmake_echo_color --cyan "Compiling ${PROJECT_NAME} with ${STR_WITH_BOTAN}, ${STR_WITH_CARES}")
+
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/biboumi.h.cmake ${CMAKE_BINARY_DIR}/src/biboumi.h) \ No newline at end of file