summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2016-06-29 19:52:43 +0200
committerlouiz’ <louiz@louiz.org>2016-06-29 19:53:37 +0200
commit79002aa5c9ada3a09d5f09cde0cac4c456adaa47 (patch)
treeba1a3736f07edde25ca3e974ece20c0bdfd2bd2b /CMakeLists.txt
parent2fe8878169b094a12d74d69ea97314d172647ea8 (diff)
downloadbiboumi-79002aa5c9ada3a09d5f09cde0cac4c456adaa47.tar.gz
biboumi-79002aa5c9ada3a09d5f09cde0cac4c456adaa47.tar.bz2
biboumi-79002aa5c9ada3a09d5f09cde0cac4c456adaa47.tar.xz
biboumi-79002aa5c9ada3a09d5f09cde0cac4c456adaa47.zip
Run e2e through with valgrind if BIBOUMI_E2E_VALGRIND is set in the env
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dc3a707..7249aa4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -205,6 +205,8 @@ add_custom_target(check COMMAND "test_suite"
DEPENDS test_suite biboumi)
add_custom_target(e2e COMMAND "python3" "${CMAKE_CURRENT_SOURCE_DIR}/tests/end_to_end/"
DEPENDS biboumi)
+add_custom_target(e2e_valgrind COMMAND "E2E_BIBOUMI_VALGRIND=1" "python3" "${CMAKE_CURRENT_SOURCE_DIR}/tests/end_to_end/"
+ DEPENDS biboumi)
#