summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2013-11-03 17:51:32 +0100
committerFlorent Le Coz <louiz@louiz.org>2013-11-03 17:51:32 +0100
commitf2f94618fcf87b4fc1ad86902c63a7a48be745b8 (patch)
treebe3e64ef9119f91b043b5c2cea96f7508158d1f9 /CMakeLists.txt
parent5bbd34a3a909fa904ee4402f01dac6bac59211b1 (diff)
downloadbiboumi-f2f94618fcf87b4fc1ad86902c63a7a48be745b8.tar.gz
biboumi-f2f94618fcf87b4fc1ad86902c63a7a48be745b8.tar.bz2
biboumi-f2f94618fcf87b4fc1ad86902c63a7a48be745b8.tar.xz
biboumi-f2f94618fcf87b4fc1ad86902c63a7a48be745b8.zip
Add a basic XMPP component implementation, doing the authentication
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1c21b84..363eb79 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,7 +8,16 @@ set(${PROJECT_NAME}_VERSION_MINOR 1)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -pedantic -Wall -Wextra")
set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -Og -fsanitize=address")
+#
+## Look for external libraries
+#
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
+find_package(Cryptopp REQUIRED)
+
include_directories("src/")
+# the SYSTEM flag tells the compiler that we don't care about warnings
+# coming from these headers.
+include_directories(SYSTEM ${CRYPTO++_INCLUDE_DIR})
#
## network