summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2013-11-21 00:37:01 +0100
committerFlorent Le Coz <louiz@louiz.org>2013-11-21 00:37:01 +0100
commit70a58a8f7152e775a1c6cdc15b3c9f23a7719f85 (patch)
treed37b7a377c3f76a2e51fe2dcebb2b19874773872 /CMakeLists.txt
parente7a441e798e0a32fc4bb4021e058f3dc080adc80 (diff)
parentb72908548dc841de65dc9288a96c1abe648acc46 (diff)
downloadbiboumi-70a58a8f7152e775a1c6cdc15b3c9f23a7719f85.tar.gz
biboumi-70a58a8f7152e775a1c6cdc15b3c9f23a7719f85.tar.bz2
biboumi-70a58a8f7152e775a1c6cdc15b3c9f23a7719f85.tar.xz
biboumi-70a58a8f7152e775a1c6cdc15b3c9f23a7719f85.zip
Merge branch 'epolletc'
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 21e82b4..2c01ee3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,6 +24,12 @@ include_directories(${ICONV_INCLUDE_DIR})
# coming from these headers.
include_directories(SYSTEM ${CRYPTO++_INCLUDE_DIR})
+set(POLLER "POLL" CACHE STRING
+ "Choose the poller between POLL and EPOLL (Linux-only)")
+if((NOT ${POLLER} MATCHES "POLL") AND
+ (NOT ${POLLER} MATCHES "EPOLL"))
+ message(FATAL_ERROR "POLLER must be either POLL or EPOLL")
+endif()
#
## utils
#
@@ -95,4 +101,4 @@ target_link_libraries(test
utils
config)
-CONFIGURE_FILE(config.h.cmake src/config.h @ONLY)
+configure_file(config.h.cmake src/config.h)