summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2019-09-15 23:07:56 +0200
committerlouiz’ <louiz@louiz.org>2019-09-17 11:26:12 +0200
commit0508a448979d850442b0df35d4fbe06f4bfb7ab4 (patch)
tree33523f271b6fd4503ecc156728e3c65b4c25d04b /CMakeLists.txt
parent26d9445029ad39ab38b054f12c748b9ad602d4eb (diff)
downloadbiboumi-0508a448979d850442b0df35d4fbe06f4bfb7ab4.tar.gz
biboumi-0508a448979d850442b0df35d4fbe06f4bfb7ab4.tar.bz2
biboumi-0508a448979d850442b0df35d4fbe06f4bfb7ab4.tar.xz
biboumi-0508a448979d850442b0df35d4fbe06f4bfb7ab4.zip
ci: Add a junit output to test_suite and give it to gitlab
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5a8d99a..b6a9437 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -313,6 +313,8 @@ endif()
#
add_custom_target(check COMMAND "test_suite"
DEPENDS test_suite)
+add_custom_target(check_junit COMMAND test_suite -r junit -o check_result.xml
+ DEPENDS test_suite)
set_target_properties(check PROPERTIES EXCLUDE_FROM_ALL TRUE)
add_custom_target(e2e COMMAND "python3" "${CMAKE_CURRENT_SOURCE_DIR}/tests/end_to_end/"
DEPENDS biboumi)
@@ -323,13 +325,14 @@ if(CMAKE_BUILD_TYPE MATCHES Debug)
include(CodeCoverage)
SETUP_TARGET_FOR_COVERAGE(coverage_check
./test_suite
- coverage_test_suite)
+ coverage_test_suite
+ "-r junit -o check_result.xml")
add_dependencies(coverage_check test_suite)
SETUP_TARGET_FOR_COVERAGE(coverage_e2e
python3
coverage_e2e
- ${CMAKE_CURRENT_SOURCE_DIR}/tests/end_to_end/)
+ "${CMAKE_CURRENT_SOURCE_DIR}/tests/end_to_end/")
add_dependencies(coverage_e2e biboumi)
ADD_CUSTOM_TARGET(coverage