summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2016-07-12 11:59:27 +0200
committerlouiz’ <louiz@louiz.org>2016-07-12 11:59:27 +0200
commit8ded8cd33ee2d171f2a6da207e01130787da7ccf (patch)
tree9f1aba6d8204341a91284b1537e37417eac1735e /CMakeLists.txt
parent2307f94e5b02c7cfbc39ca57eb8c9133f6b10ee5 (diff)
downloadbiboumi-8ded8cd33ee2d171f2a6da207e01130787da7ccf.tar.gz
biboumi-8ded8cd33ee2d171f2a6da207e01130787da7ccf.tar.bz2
biboumi-8ded8cd33ee2d171f2a6da207e01130787da7ccf.tar.xz
biboumi-8ded8cd33ee2d171f2a6da207e01130787da7ccf.zip
Properly use the docstring variables
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2b1736d..a7bccd7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -284,19 +284,19 @@ configure_file(biboumi.h.cmake src/biboumi.h)
set(SYSTEMD_SERVICE_TYPE_DOCSTRING "The value used as the Type= in the systemd unit file.")
set(WATCHDOG_SEC_DOCSTRING "The value used as WatchdogSec= in the systemd unit file.")
if(SYSTEMD_FOUND)
- set(SYSTEMD_SERVICE_TYPE "notify" CACHE STRING SYSTEMD_SERVICE_TYPE_DOCSTRING)
- set(WATCHDOG_SEC "20" CACHE STRING WATCHDOG_SEC_DOCSTRING)
+ set(SYSTEMD_SERVICE_TYPE "notify" CACHE STRING ${SYSTEMD_SERVICE_TYPE_DOCSTRING})
+ set(WATCHDOG_SEC "20" CACHE STRING ${WATCHDOG_SEC_DOCSTRING})
else()
- set(SYSTEMD_SERVICE_TYPE "simple" CACHE STRING SYSTEMD_SERVICE_TYPE_DOCSTRING)
- set(WATCHDOG_SEC "" CACHE STRING WATCHDOG_SEC_DOCSTRING)
+ set(SYSTEMD_SERVICE_TYPE "simple" CACHE STRING ${SYSTEMD_SERVICE_TYPE_DOCSTRING})
+ set(WATCHDOG_SEC "" CACHE STRING ${WATCHDOG_SEC_DOCSTRING})
endif()
set(SERVICE_USER_DOCSTRING "The value used as the User= in the systemd unit file.")
if(NOT DEFINED SERVICE_USER)
- set(SERVICE_USER "nobody" CACHE STRING SERVICE_USER_DOCSTRING)
+ set(SERVICE_USER "nobody" CACHE STRING ${SERVICE_USER_DOCSTRING})
endif()
set(SERVICE_GROUP_DOCSTRING "The value used as the Group= in the systemd unit file.")
if(NOT DEFINED SERVICE_GROUP)
- set(SERVICE_GROUP "nobody" CACHE STRING SERVICE_GROUP_DOCSTRING)
+ set(SERVICE_GROUP "nobody" CACHE STRING ${SERVICE_GROUP_DOCSTRING})
endif()
configure_file(unit/biboumi.service.cmake biboumi.service)