summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2016-11-15 00:23:19 +0100
committerlouiz’ <louiz@louiz.org>2016-11-15 00:23:19 +0100
commitd872c2b49214c0a4db40a9e2d860802d9eedc563 (patch)
treecccd27de262b2823d126a48c82455d208696dbdc /CMakeLists.txt
parented7e66471f7018f2e7e1c6a469e5cd758b913255 (diff)
downloadbiboumi-d872c2b49214c0a4db40a9e2d860802d9eedc563.tar.gz
biboumi-d872c2b49214c0a4db40a9e2d860802d9eedc563.tar.bz2
biboumi-d872c2b49214c0a4db40a9e2d860802d9eedc563.tar.xz
biboumi-d872c2b49214c0a4db40a9e2d860802d9eedc563.zip
Support the ident protocol
fix #3211
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4b51b87..10815b7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -155,6 +155,19 @@ if(USE_DATABASE)
endif()
#
+## identd
+#
+file(GLOB source_identd
+ src/identd/*.[hc]pp)
+add_library(identd STATIC ${source_identd})
+target_link_libraries(identd bridge network utils src_utils logger)
+
+if(USE_DATABASE)
+ target_link_libraries(xmpp database)
+ target_link_libraries(irc database)
+endif()
+
+#
## bridge
#
file(GLOB source_bridge
@@ -172,6 +185,7 @@ target_link_libraries(${PROJECT_NAME}
bridge
utils
src_utils
+ identd
config)
if(SYSTEMD_FOUND)
target_link_libraries(xmpp ${SYSTEMD_LIBRARIES})