summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2016-07-12 11:57:01 +0200
committerlouiz’ <louiz@louiz.org>2016-07-12 11:57:01 +0200
commit2307f94e5b02c7cfbc39ca57eb8c9133f6b10ee5 (patch)
treeec284857884b4cff4950a0bd68872bada656ed2b /CMakeLists.txt
parentf212b47830b4ef6473bbcfaab33297a169643d8b (diff)
downloadbiboumi-2307f94e5b02c7cfbc39ca57eb8c9133f6b10ee5.tar.gz
biboumi-2307f94e5b02c7cfbc39ca57eb8c9133f6b10ee5.tar.bz2
biboumi-2307f94e5b02c7cfbc39ca57eb8c9133f6b10ee5.tar.xz
biboumi-2307f94e5b02c7cfbc39ca57eb8c9133f6b10ee5.zip
Clean the list of options visible in non-advanced ccmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 11 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 06121a7..2b1736d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -80,6 +80,7 @@ if (NOT PANDOC_EXECUTABLE)
message(STATUS "Pandoc not found, documentation cannot be built")
endif()
endif()
+mark_as_advanced(PANDOC_EXECUTABLE)
# Look for litesql and enable the database if found
if(WITH_LITESQL)
@@ -280,18 +281,22 @@ add_custom_target(PrintBuildParameters ALL
configure_file(biboumi.h.cmake src/biboumi.h)
+set(SYSTEMD_SERVICE_TYPE_DOCSTRING "The value used as the Type= in the systemd unit file.")
+set(WATCHDOG_SEC_DOCSTRING "The value used as WatchdogSec= in the systemd unit file.")
if(SYSTEMD_FOUND)
- set(SYSTEMD_SERVICE_TYPE "notify")
- set(WATCHDOG_SEC "20")
+ set(SYSTEMD_SERVICE_TYPE "notify" CACHE STRING SYSTEMD_SERVICE_TYPE_DOCSTRING)
+ set(WATCHDOG_SEC "20" CACHE STRING WATCHDOG_SEC_DOCSTRING)
else()
- set(SYSTEMD_SERVICE_TYPE "simple")
- set(WATCHDOG_SEC "")
+ set(SYSTEMD_SERVICE_TYPE "simple" CACHE STRING SYSTEMD_SERVICE_TYPE_DOCSTRING)
+ set(WATCHDOG_SEC "" CACHE STRING WATCHDOG_SEC_DOCSTRING)
endif()
+set(SERVICE_USER_DOCSTRING "The value used as the User= in the systemd unit file.")
if(NOT DEFINED SERVICE_USER)
- set(SERVICE_USER "nobody")
+ set(SERVICE_USER "nobody" CACHE STRING SERVICE_USER_DOCSTRING)
endif()
+set(SERVICE_GROUP_DOCSTRING "The value used as the Group= in the systemd unit file.")
if(NOT DEFINED SERVICE_GROUP)
- set(SERVICE_GROUP "nobody")
+ set(SERVICE_GROUP "nobody" CACHE STRING SERVICE_GROUP_DOCSTRING)
endif()
configure_file(unit/biboumi.service.cmake biboumi.service)