summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2016-08-20 02:36:01 +0200
committerlouiz’ <louiz@louiz.org>2016-08-20 02:36:01 +0200
commitd6a22b27f37ea711bcc04ccd699c703696e6b377 (patch)
treef7c78c19ea473469b39c21b0106b32333570040c /CMakeLists.txt
parent7d05f9b6aedd9153bd7787a5a83b9840b1991a7e (diff)
downloadbiboumi-d6a22b27f37ea711bcc04ccd699c703696e6b377.tar.gz
biboumi-d6a22b27f37ea711bcc04ccd699c703696e6b377.tar.bz2
biboumi-d6a22b27f37ea711bcc04ccd699c703696e6b377.tar.xz
biboumi-d6a22b27f37ea711bcc04ccd699c703696e6b377.zip
Better dependencies for make rpm and dist
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bb614fd..81c7da1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -246,7 +246,7 @@ install(FILES conf/biboumi.cfg DESTINATION /etc/bib
## Dist target
## Generate a release tarball from the git sources
#
-add_custom_target(dist
+add_custom_command(OUTPUT ${ARCHIVE_NAME}.tar.xz
COMMAND git archive --prefix=${ARCHIVE_NAME}/ --format=tar HEAD
> ${CMAKE_CURRENT_BINARY_DIR}/${ARCHIVE_NAME}.tar
# Append this specific file that is not part of the git repo
@@ -258,13 +258,15 @@ add_custom_target(dist
COMMAND ${CMAKE_COMMAND} -E cmake_echo_color --cyan "${ARCHIVE_NAME}.tar.xz created."
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
)
-add_dependencies(dist catch)
+add_custom_target(dist
+ DEPENDS ${ARCHIVE_NAME}.tar.xz
+ DEPENDS catch)
add_custom_target(rpm
+ DEPENDS dist
COMMAND mkdir -p rpmbuild/{BUILD,RPMS,SOURCES,SPECS,SRPMS}
COMMAND rpmbuild --define "_topdir `pwd`/rpmbuild/" --define "_sourcedir `pwd`" -ba biboumi.spec
)
-add_dependencies(rpm dist)
if(BOTAN_FOUND)
set(STR_WITH_BOTAN "Botan: yes")