summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2013-11-10 20:47:11 +0100
committerFlorent Le Coz <louiz@louiz.org>2013-11-10 20:47:11 +0100
commitf0d9273da61ce154dbe460cf58c98de851d30615 (patch)
treebbca8a7adca39ced153a7f4d04d3964692bd4f5d /CMakeLists.txt
parent10d528717723a72dd3240c634980a461cf9fa2df (diff)
downloadbiboumi-f0d9273da61ce154dbe460cf58c98de851d30615.tar.gz
biboumi-f0d9273da61ce154dbe460cf58c98de851d30615.tar.bz2
biboumi-f0d9273da61ce154dbe460cf58c98de851d30615.tar.xz
biboumi-f0d9273da61ce154dbe460cf58c98de851d30615.zip
Add a Config module, and use it to get the password from a file
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 16 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a7ff1d4..b0fae9e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -33,6 +33,14 @@ add_library(utils STATIC ${source_utils})
target_link_libraries(utils ${ICONV_LIBRARIES})
#
+## config
+#
+file(GLOB source_config
+ src/config/*.[hc]pp)
+add_library(config STATIC ${source_config})
+target_link_libraries(config utils)
+
+#
## network
#
file(GLOB source_network
@@ -64,11 +72,16 @@ file(GLOB source_bridge
add_library(bridge STATIC ${source_bridge})
target_link_libraries(bridge xmpp irc)
+#
+## Main executable
+#
add_executable(${PROJECT_NAME} src/main.cpp)
target_link_libraries(${PROJECT_NAME}
xmpp
irc
- bridge)
+ bridge
+ utils
+ config)
#
## Tests
@@ -79,6 +92,7 @@ target_link_libraries(test
xmpp
irc
bridge
- utils)
+ utils
+ config)
CONFIGURE_FILE(config.h.cmake src/config.h @ONLY)