summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2017-05-16 14:21:03 +0200
committerlouiz’ <louiz@louiz.org>2017-05-16 14:21:03 +0200
commit9d1dc9138fdb0377c5eb93da285893ba97e43a44 (patch)
tree6ba68c93f0cf13d2068917df192246ebc557030e /CMakeLists.txt
parent8cf0b833c47314ada66e6a25bbdb9a2178e096d0 (diff)
downloadbiboumi-9d1dc9138fdb0377c5eb93da285893ba97e43a44.tar.gz
biboumi-9d1dc9138fdb0377c5eb93da285893ba97e43a44.tar.bz2
biboumi-9d1dc9138fdb0377c5eb93da285893ba97e43a44.tar.xz
biboumi-9d1dc9138fdb0377c5eb93da285893ba97e43a44.zip
Make the default build type Release (instead of empty string)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ba20de1..4cc9898 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,11 @@ set(${PROJECT_NAME}_VERSION_MAJOR 5)
set(${PROJECT_NAME}_VERSION_MINOR 0)
set(${PROJECT_NAME}_VERSION_SUFFIX "~dev")
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE "Debug" CACHE STRING
+ "Build type (Release/Debug/RelWithDebInfo/MinSizeRel)" FORCE)
+endif()
+
#
## Find optional instrumentation libraries that will be used in debug only
#