summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2013-11-10 02:26:07 +0100
committerFlorent Le Coz <louiz@louiz.org>2013-11-10 02:30:22 +0100
commit3d92360310d8e35394109058ff723da57af5b380 (patch)
treea268ca56705b09251151919c51daef63f04bee22 /CMakeLists.txt
parent8acd7a02aeda01c0ac828b05c36f10bbacaea70e (diff)
downloadbiboumi-3d92360310d8e35394109058ff723da57af5b380.tar.gz
biboumi-3d92360310d8e35394109058ff723da57af5b380.tar.bz2
biboumi-3d92360310d8e35394109058ff723da57af5b380.tar.xz
biboumi-3d92360310d8e35394109058ff723da57af5b380.zip
Use the Expat library directly instead of relying on expatpp
And now we handle namespaces, yay. And a nice little test.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bd8ca76..2ec9dd0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,11 +13,14 @@ set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -Og -fsanitize=address")
#
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/cmake/Modules/")
find_package(Cryptopp REQUIRED)
+include(FindEXPAT)
+find_package(EXPAT REQUIRED)
include_directories("src/")
# the SYSTEM flag tells the compiler that we don't care about warnings
# coming from these headers.
include_directories(SYSTEM ${CRYPTO++_INCLUDE_DIR})
+include_directories(SYSTEM ${EXPAT_INCLUDE_DIRS})
#
## utils
@@ -47,7 +50,8 @@ target_link_libraries(irc network utils)
file(GLOB source_xmpp
src/xmpp/*.[hc]pp)
add_library(xmpp STATIC ${source_xmpp})
-target_link_libraries(xmpp bridge network utils ${CRYPTO++_LIBRARIES} expatpp)
+target_link_libraries(xmpp bridge network utils
+ ${CRYPTO++_LIBRARIES} ${EXPAT_LIBRARIES})
#
## bridge