summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2016-09-17 01:08:32 +0200
committerlouiz’ <louiz@louiz.org>2016-09-17 01:08:32 +0200
commitf8112468a7a557db21aa76c3620d55172cb9bdb4 (patch)
treeedc7fa5e93d6b3c5c33cc4d0e1f02e2eda9c6bc7 /CMakeLists.txt
parentaaa2ca670ab5f19390e77a1f5ea88017b312ceaf (diff)
downloadbiboumi-f8112468a7a557db21aa76c3620d55172cb9bdb4.tar.gz
biboumi-f8112468a7a557db21aa76c3620d55172cb9bdb4.tar.bz2
biboumi-f8112468a7a557db21aa76c3620d55172cb9bdb4.tar.xz
biboumi-f8112468a7a557db21aa76c3620d55172cb9bdb4.zip
make dist creates the archive with the current time, not the git time
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9db8a30..252f437 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -247,7 +247,7 @@ install(FILES conf/biboumi.cfg DESTINATION /etc/bib
## Generate a release tarball from the git sources
#
add_custom_command(OUTPUT ${ARCHIVE_NAME}.tar.xz
- COMMAND git archive --prefix=${ARCHIVE_NAME}/ --format=tar HEAD
+ COMMAND git archive --prefix=${ARCHIVE_NAME}/ --format=tar HEAD^{tree}
> ${CMAKE_CURRENT_BINARY_DIR}/${ARCHIVE_NAME}.tar
# Append this specific file that is not part of the git repo
COMMAND tar -rf ${CMAKE_CURRENT_BINARY_DIR}/${ARCHIVE_NAME}.tar -P ${SOURCE_DIR}/single_include/catch.hpp --xform 's|/.*/|${ARCHIVE_NAME}/tests/|g'