summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2015-10-29 03:55:57 +0100
committerFlorent Le Coz <louiz@louiz.org>2015-10-29 03:55:57 +0100
commitf03d1a16ddca85ccfabc9cad01ed206d75301043 (patch)
tree9952ebf18a7c41ca212e1b8c7526e5c50c4ab790 /CMakeLists.txt
parent580b721ba580d27be94b8977e8bbadf359feb2a3 (diff)
downloadbiboumi-f03d1a16ddca85ccfabc9cad01ed206d75301043.tar.gz
biboumi-f03d1a16ddca85ccfabc9cad01ed206d75301043.tar.bz2
biboumi-f03d1a16ddca85ccfabc9cad01ed206d75301043.tar.xz
biboumi-f03d1a16ddca85ccfabc9cad01ed206d75301043.zip
Only download Catch when the test_suite target is built
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 64e21e0..060fa11 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -175,6 +175,7 @@ ExternalProject_Add(catch
BUILD_COMMAND ""
INSTALL_COMMAND ""
)
+set_target_properties(catch PROPERTIES EXCLUDE_FROM_ALL TRUE)
ExternalProject_Get_Property(catch SOURCE_DIR)
target_include_directories(test_suite
PUBLIC "${SOURCE_DIR}/include/"