summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2015-10-29 03:20:39 +0100
committerFlorent Le Coz <louiz@louiz.org>2015-10-29 03:20:39 +0100
commit9fe94215daecf21246e19ba59ef83755129a4a8b (patch)
tree997469992e1bda04ca1a22f77d0e89d3143781f7 /CMakeLists.txt
parent3b7bbe147229ee06de8b024e42e86d435cb0f72e (diff)
downloadbiboumi-9fe94215daecf21246e19ba59ef83755129a4a8b.tar.gz
biboumi-9fe94215daecf21246e19ba59ef83755129a4a8b.tar.bz2
biboumi-9fe94215daecf21246e19ba59ef83755129a4a8b.tar.xz
biboumi-9fe94215daecf21246e19ba59ef83755129a4a8b.zip
Make lcov gcov etc optional
make coverage will display an error instead
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d8633d8..64e21e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -186,7 +186,7 @@ add_custom_target(check COMMAND "test_suite"
#
## Code coverage
#
-if(CMAKE_BUILD_TYPE MATCHES DEBUG)
+if(CMAKE_BUILD_TYPE MATCHES Debug)
include(CodeCoverage)
SETUP_TARGET_FOR_COVERAGE(coverage
test_suite