summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2016-01-13 16:13:45 +0100
committerFlorent Le Coz <louiz@louiz.org>2016-01-13 16:14:10 +0100
commit85dfe066655654eca18d180e5b165485bcbc20ab (patch)
tree3a5eeeaa5b79aa841a328b707972f98632c0d917 /CMakeLists.txt
parent3497b330dc4aa848582da085e94ac20e6871731e (diff)
downloadbiboumi-85dfe066655654eca18d180e5b165485bcbc20ab.tar.gz
biboumi-85dfe066655654eca18d180e5b165485bcbc20ab.tar.bz2
biboumi-85dfe066655654eca18d180e5b165485bcbc20ab.tar.xz
biboumi-85dfe066655654eca18d180e5b165485bcbc20ab.zip
Include catch.hpp in the dist tarball
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 562b21f..1e8f7dd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -215,7 +215,13 @@ install(FILES conf/biboumi.cfg DESTINATION /etc/bib
#
add_custom_target(dist
COMMAND git archive --prefix=${ARCHIVE_NAME}/ --format=tar HEAD
- | xz > ${CMAKE_CURRENT_BINARY_DIR}/${ARCHIVE_NAME}.tar.xz
+ > ${CMAKE_CURRENT_BINARY_DIR}/${ARCHIVE_NAME}.tar
+ # Append this specific file that is not part of the git repo
+ COMMAND tar -rf ${CMAKE_CURRENT_BINARY_DIR}/${ARCHIVE_NAME}.tar -P ${SOURCE_DIR}/single_include/catch.hpp --xform 's|/.*/|${ARCHIVE_NAME}/tests/|g'
+ # Remove a potential existing archive
+ COMMAND rm -f ${CMAKE_CURRENT_BINARY_DIR}/${ARCHIVE_NAME}.tar.xz
+ # Compress the archive
+ COMMAND xz ${CMAKE_CURRENT_BINARY_DIR}/${ARCHIVE_NAME}.tar
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
if(BOTAN_FOUND)