summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2016-01-21 16:48:42 +0100
committerFlorent Le Coz <louiz@louiz.org>2016-01-21 16:53:29 +0100
commit85867976dcf27427708927ebebd3d8a4866e706b (patch)
treeb7185fef50507cfd7c326d8a9287ed50acfb96af /CMakeLists.txt
parentae7c54f3737b3646edfa5c4d4d7fd553aa296da6 (diff)
downloadbiboumi-85867976dcf27427708927ebebd3d8a4866e706b.tar.gz
biboumi-85867976dcf27427708927ebebd3d8a4866e706b.tar.bz2
biboumi-85867976dcf27427708927ebebd3d8a4866e706b.tar.xz
biboumi-85867976dcf27427708927ebebd3d8a4866e706b.zip
Add a “rpm” target in the makefile, building a RPM
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 167415e..e371bf6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -230,7 +230,15 @@ add_custom_target(dist
# Compress the archive
COMMAND xz ${CMAKE_CURRENT_BINARY_DIR}/${ARCHIVE_NAME}.tar
COMMAND ${CMAKE_COMMAND} -E cmake_echo_color --cyan "${ARCHIVE_NAME}.tar.xz created."
- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})
+ WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
+ )
+add_dependencies(dist catch)
+
+add_custom_target(rpm
+ COMMAND mkdir -p rpmbuild/{BUILD,RPMS,SOURCES,SPECS,SRPMS}
+ COMMAND rpmbuild --define "_topdir `pwd`/rpmbuild/" --define "_sourcedir `pwd`" -ba biboumi.spec
+ )
+add_dependencies(rpm dist)
if(BOTAN_FOUND)
set(STR_WITH_BOTAN "Botan: yes")