summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2015-05-28 23:44:44 +0200
committerFlorent Le Coz <louiz@louiz.org>2015-05-28 23:46:24 +0200
commit427df5fc2a5f1ea0ee4e31ceafba9c6cc5803fd2 (patch)
treec9ce612fd8458b36aca73fce413dc0ed2170615c /CMakeLists.txt
parente1a7114c8daa10589c830ce972cf461c3540111b (diff)
downloadbiboumi-427df5fc2a5f1ea0ee4e31ceafba9c6cc5803fd2.tar.gz
biboumi-427df5fc2a5f1ea0ee4e31ceafba9c6cc5803fd2.tar.bz2
biboumi-427df5fc2a5f1ea0ee4e31ceafba9c6cc5803fd2.tar.xz
biboumi-427df5fc2a5f1ea0ee4e31ceafba9c6cc5803fd2.zip
Revert "Use git-archive-all in the make dist, to include the submodules in the archive"
This reverts commit 54f96debcaa80ea2d49f722b0df11d227943ebba.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 301d91d..617c113 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -153,5 +153,6 @@ endif()
## Generate a release tarball from the git sources
#
add_custom_target(dist
- COMMAND git-archive-all ${CMAKE_CURRENT_BINARY_DIR}/${ARCHIVE_NAME}.tar.xz
+ COMMAND git archive --prefix=${ARCHIVE_NAME}/ --format=tar HEAD
+ | xz > ${CMAKE_CURRENT_BINARY_DIR}/${ARCHIVE_NAME}.tar.xz
WORKING_DIRECTORY ${CMAKE_SOURCE_DIR})