summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2016-01-14 14:33:49 +0100
committerFlorent Le Coz <louiz@louiz.org>2016-01-14 14:39:06 +0100
commitd58dcde856aa1885e0eb4a1286eeaa6e4861557b (patch)
tree871bfe7eab7960e23995721eb807324ab55152cd /CMakeLists.txt
parent0864f2ab99073b62e4173da694a13aa4ccc8b554 (diff)
downloadbiboumi-d58dcde856aa1885e0eb4a1286eeaa6e4861557b.tar.gz
biboumi-d58dcde856aa1885e0eb4a1286eeaa6e4861557b.tar.bz2
biboumi-d58dcde856aa1885e0eb4a1286eeaa6e4861557b.tar.xz
biboumi-d58dcde856aa1885e0eb4a1286eeaa6e4861557b.zip
Only activate systemd’s watchdog if we are compiling with systemd
ref #3152
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b51444a..ba3213b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -242,7 +242,9 @@ configure_file(biboumi.h.cmake src/biboumi.h)
if(SYSTEMD_FOUND)
set(SYSTEMD_SERVICE_TYPE "notify")
+ set(WATCHDOG_SEC "20")
else()
set(SYSTEMD_SERVICE_TYPE "simple")
+ set(WATCHDOG_SEC "")
endif()
configure_file(unit/biboumi.service.cmake biboumi.service)