summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2016-01-15 11:54:33 +0100
committerFlorent Le Coz <louiz@louiz.org>2016-01-15 11:54:33 +0100
commitccfdb60cc1b63cec2a97eaaaec23ca547b7f2a09 (patch)
tree8615fdfc9705d1d0325795c1df20ca3e351fb901 /CMakeLists.txt
parentd58dcde856aa1885e0eb4a1286eeaa6e4861557b (diff)
downloadbiboumi-ccfdb60cc1b63cec2a97eaaaec23ca547b7f2a09.tar.gz
biboumi-ccfdb60cc1b63cec2a97eaaaec23ca547b7f2a09.tar.bz2
biboumi-ccfdb60cc1b63cec2a97eaaaec23ca547b7f2a09.tar.xz
biboumi-ccfdb60cc1b63cec2a97eaaaec23ca547b7f2a09.zip
Fix a build when litesql is found but not botan
fix #3157
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ba3213b..7e356c9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -84,7 +84,10 @@ if(LITESQL_FOUND)
add_library(database STATIC src/database/database.cpp
${LITESQL_GENERATED_SOURCES})
- target_link_libraries(database ${LITESQL_LIBRARIES} ${BOTAN_LIBRARIES})
+ target_link_libraries(database ${LITESQL_LIBRARIES})
+ if(BOTAN_FOUND)
+ target_link_libraries(database ${BOTAN_LIBRARIES})
+ endif()
set(USE_DATABASE TRUE)
endif()