summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2019-08-04 04:55:33 +0200
committerlouiz’ <louiz@louiz.org>2019-08-04 04:55:33 +0200
commita8cd24148522473caba5ba46b06c9b7b5f6633a9 (patch)
tree82a2b3d17cc68004c8af7fb9efcf379e1ca5884e /CMakeLists.txt
parentce7b8395d0091af1b654d01c0ac21913907d8820 (diff)
downloadbiboumi-a8cd24148522473caba5ba46b06c9b7b5f6633a9.tar.gz
biboumi-a8cd24148522473caba5ba46b06c9b7b5f6633a9.tar.bz2
biboumi-a8cd24148522473caba5ba46b06c9b7b5f6633a9.tar.xz
biboumi-a8cd24148522473caba5ba46b06c9b7b5f6633a9.zip
Disable systemd’s watchdog by default
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e217171..ebf63ab 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -379,12 +379,11 @@ add_custom_target(rpm
#
set(SYSTEMD_SERVICE_TYPE_DOCSTRING "The value used as the Type= in the systemd unit file.")
set(WATCHDOG_SEC_DOCSTRING "The value used as WatchdogSec= in the systemd unit file.")
+set(WATCHDOG_SEC "" CACHE STRING ${WATCHDOG_SEC_DOCSTRING})
if(SYSTEMD_FOUND)
set(SYSTEMD_SERVICE_TYPE "notify" CACHE STRING ${SYSTEMD_SERVICE_TYPE_DOCSTRING})
- set(WATCHDOG_SEC "20" CACHE STRING ${WATCHDOG_SEC_DOCSTRING})
else()
set(SYSTEMD_SERVICE_TYPE "simple" CACHE STRING ${SYSTEMD_SERVICE_TYPE_DOCSTRING})
- set(WATCHDOG_SEC "" CACHE STRING ${WATCHDOG_SEC_DOCSTRING})
endif()
set(SERVICE_USER_DOCSTRING "The value used as the User= in the systemd unit file.")
if(NOT DEFINED SERVICE_USER)