summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2017-02-01 20:33:16 +0100
committerlouiz’ <louiz@louiz.org>2017-02-01 20:33:16 +0100
commit835c650ef5a7297cc8bd0d6e0799186e6a5d2126 (patch)
treec7214e2a9eccc882ab9221bba37f65bf48dfd611 /CMakeLists.txt
parent479b7189935baa4ca9c9d2a5525bdb1fbd8b9fef (diff)
downloadbiboumi-835c650ef5a7297cc8bd0d6e0799186e6a5d2126.tar.gz
biboumi-835c650ef5a7297cc8bd0d6e0799186e6a5d2126.tar.bz2
biboumi-835c650ef5a7297cc8bd0d6e0799186e6a5d2126.tar.xz
biboumi-835c650ef5a7297cc8bd0d6e0799186e6a5d2126.zip
Actually, just use the C locale for the date formats
We don’t need any UTF-8 support here, and it’s more portable
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1766e58..da9cf37 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -332,7 +332,7 @@ endif()
configure_file(unit/biboumi.service.cmake biboumi.service)
# Force the format of the date output
-set(ENV{LANG} "C.UTF-8")
+set(ENV{LANG} "C")
execute_process(COMMAND "date" "+%a %b %d %Y" OUTPUT_VARIABLE RPM_DATE
OUTPUT_STRIP_TRAILING_WHITESPACE)
unset(ENV{LANG})