summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFlorent Le Coz <louiz@louiz.org>2016-02-23 19:20:00 +0100
committerFlorent Le Coz <louiz@louiz.org>2016-02-24 09:30:37 +0100
commit51a34f83f9cae36f65b021e379e411cacf84c054 (patch)
treeaaa3f0cce0b8aea841d1b486ad930ba56324699f /CMakeLists.txt
parent37fd6ff18a6e51ee5c4127b7e1269e3944d71b44 (diff)
downloadbiboumi-51a34f83f9cae36f65b021e379e411cacf84c054.tar.gz
biboumi-51a34f83f9cae36f65b021e379e411cacf84c054.tar.bz2
biboumi-51a34f83f9cae36f65b021e379e411cacf84c054.tar.xz
biboumi-51a34f83f9cae36f65b021e379e411cacf84c054.zip
Add a basic integration test in python
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e371bf6..2f1bdd8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -195,7 +195,8 @@ if(NOT EXISTS ${CMAKE_SOURCE_DIR}/tests/catch.hpp)
add_dependencies(test_suite catch)
endif()
add_custom_target(check COMMAND "test_suite"
- DEPENDS test_suite)
+ COMMAND "python3" "${CMAKE_CURRENT_SOURCE_DIR}/tests/end_to_end/"
+ DEPENDS test_suite biboumi)
#
## Code coverage