summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlouiz’ <louiz@louiz.org>2019-09-12 14:20:31 +0200
committerlouiz’ <louiz@louiz.org>2019-09-15 21:45:06 +0200
commit2ad098de92af238863d8bed233f5610ab7486d95 (patch)
tree0c60ffb9fae26b5e785b70ceac3ca97622cce882 /CMakeLists.txt
parentdb3c5f4bc48331c1ee687fa18c1906fb139f502c (diff)
downloadbiboumi-2ad098de92af238863d8bed233f5610ab7486d95.tar.gz
biboumi-2ad098de92af238863d8bed233f5610ab7486d95.tar.bz2
biboumi-2ad098de92af238863d8bed233f5610ab7486d95.tar.xz
biboumi-2ad098de92af238863d8bed233f5610ab7486d95.zip
Properly build and install the man page, also in the rpm
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ebf63ab..5a8d99a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,8 +74,11 @@ set(SOFTWARE_VERSION
#
## The rule that generates the documentation
#
-add_custom_target(doc COMMAND make html BUILDDIR=${CMAKE_CURRENT_BINARY_DIR}
+add_custom_target(html COMMAND make html BUILDDIR=${CMAKE_CURRENT_BINARY_DIR}
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/doc)
+add_custom_target(man COMMAND make man BUILDDIR=${CMAKE_CURRENT_BINARY_DIR}
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/doc)
+add_custom_target(doc DEPENDS html man)
#
## Set this search path for cmake, to find our custom search modules
@@ -309,7 +312,7 @@ endif()
## Add some custom rules to launch the tests
#
add_custom_target(check COMMAND "test_suite"
- DEPENDS test_suite biboumi)
+ DEPENDS test_suite)
set_target_properties(check PROPERTIES EXCLUDE_FROM_ALL TRUE)
add_custom_target(e2e COMMAND "python3" "${CMAKE_CURRENT_SOURCE_DIR}/tests/end_to_end/"
DEPENDS biboumi)
@@ -343,7 +346,7 @@ add_custom_target(everything DEPENDS test_suite biboumi)
## Install target
#
install(TARGETS ${PROJECT_NAME} RUNTIME DESTINATION bin)
-install(FILES ${MAN_PAGE} DESTINATION share/man/man1 OPTIONAL COMPONENT documentation)
+install(FILES ${CMAKE_CURRENT_BINARY_DIR}/man/biboumi.1 DESTINATION share/man/man1 OPTIONAL COMPONENT documentation)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/biboumi.service DESTINATION lib/systemd/system COMPONENT init)
file(GLOB policy_files conf/*policy.txt)
install(FILES ${policy_files} DESTINATION /etc/biboumi COMPONENT configuration)